Quoting Henrik Gramner (2015-09-06 01:06:12)
> ---
>  libavcodec/v210enc.c      | 15 +++++---
>  libavcodec/v210enc.h      |  2 +
>  tests/checkasm/Makefile   |  1 +
>  tests/checkasm/checkasm.c |  3 ++
>  tests/checkasm/checkasm.h |  1 +
>  tests/checkasm/v210enc.c  | 94 
> +++++++++++++++++++++++++++++++++++++++++++++++
>  6 files changed, 111 insertions(+), 5 deletions(-)
>  create mode 100644 tests/checkasm/v210enc.c
> 
> diff --git a/libavcodec/v210enc.c b/libavcodec/v210enc.c
> index 42cbb86..ca6ad2e 100644
> --- a/libavcodec/v210enc.c
> +++ b/libavcodec/v210enc.c
> @@ -82,6 +82,15 @@ static void v210_planar_pack_10_c(const uint16_t *y, const 
> uint16_t *u,
>      }
>  }
>  
> +av_cold void ff_v210enc_init(V210EncContext *s)

Perhaps this should be called ff_v210enc_dsp_init() or something along
those lines, so people don't add other stuff to it by mistake.

-- 
Anton Khirnov
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to