On Tue, Feb 7, 2017 at 8:15 AM, Alexandra Hájková
<alexandra.khirn...@gmail.com> wrote:
> the ASF specific Format Data size. Fixes video decoding problem
> part of the bug 1020.
> ---
>  libavformat/asfdec.c  | 8 +++++---
>  libavformat/avidec.c  | 2 +-
>  libavformat/riff.h    | 2 +-
>  libavformat/riffdec.c | 6 ++++--
>  libavformat/wtv.c     | 2 +-
>  5 files changed, 12 insertions(+), 8 deletions(-)
>
> diff --git a/libavformat/asfdec.c b/libavformat/asfdec.c
> index d602af8..10f8644 100644
> --- a/libavformat/asfdec.c
> +++ b/libavformat/asfdec.c
> @@ -691,16 +691,18 @@ static int asf_read_properties(AVFormatContext *s, 
> const GUIDParseTable *g)
>
>  static int parse_video_info(AVIOContext *pb, AVStream *st)
>  {
> -    uint16_t size;
> +    uint16_t size_;
> +    uint32_t size;

This is a big NO from me. You should rename them according to what
they actually are (eg size_format_data and size_bmp_header).
-- 
Vittorio
_______________________________________________
libav-devel mailing list
libav-devel@libav.org
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to