2016-09-16 18:16 GMT+02:00 Philippe Gorley
<philippe.gor...@savoirfairelinux.com>:
> I'm looking to upgrade my application (I'm currently using FFmpeg from the 
> Ubuntu 16.04 repo)
> to a more recent release of FFmpeg, such as 3.1.3. Everything went well, 
> except that
> avformat_find_stream_info now times out on my RTP stream, although it does 
> eventually
> return the info. I've tried linking against master with the same result. 
> Doing some
> investigation, I found that release 2.8.6 does not exhibit this behaviour, 
> while 2.8.7 does.

(Which change introduced the issue but see below first?)

[...]

> I've compiled FFmpeg with the following configuration:
> ./configure --prefix=/usr/local --disable-everything --disable-programs 
> --enable-protocols
> --enable-demuxers --enable-parser=h264 --enable-decoder=h264 
> --enable-indev=v4l2
> --enable-shared
>
> Is this timeout a known bug?

Is the issue reproducible with current FFmpeg git head?
I believe a similar issue was fixed recently.

Is it also reproducible with "./ffmpeg -i rtp://hostname:port"?
Is it also reproducible if you build with "./configure && make"?

Carl Eugen
_______________________________________________
Libav-user mailing list
Libav-user@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/libav-user

Reply via email to