> Hi,
 > I've moved libdbi to 0.9.0 in CVS and I've hoped to get libdbi-drivers
 > release-ready as well. I've installed PostgreSQL 9.2 today to see if
 > things worked as smoothly as they did a while back. I had to learn
 > that the test harness doesn't manage to get through the database
 > encoding test. After disabling that one, I still get 47 failures,
 > while both mysql and sqlite3 succeed without a hitch. Is anyone using
 > PostgreSQL with libdbi, and if yes, which versions?

kinda talking to myself, but maybe someone's still listening...

Turns out that there were both encoding and binary data
issues. PostgreSQL >= 9.0 uses hex-encoded binary data which screwed
up all tests related to BYTEA data. I had to rewrite the entire BYTEA
decoding stuff in the pgsql driver to handle this new format. We're
now back at 0 errors, but I can test this against PostgreSQL 9.2
only. Would someone be kind enough to test the code on older versions
of this engine?


Markus Hoenicka
AQ score 38

Free Next-Gen Firewall Hardware Offer
Buy your Sophos next-gen firewall before the end March 2013 
and get the hardware for free! Learn more.
libdbi-users mailing list

Reply via email to