I installed the 0.8.3 libdbi/libdbi-devl packages from the yum repos. I did 
clone the latest version from git but there was configure file to compile it.



At 2014-09-08 15:50 S M was heard to say:
Hi,
>
>I'm trying compile libdbi with DB2 support. I've downloaded the latest version 
>(libdbi-drivers-0.9.0) and exec'ed 
>
>./configure --with-db2 --with-db2-incdir=/opt/ibm/db2/V10.5/include 
>--with-db2-dir=/opt/ibm/db2/V10.5
>
>That part worked. But when running 'make' it fails with:
>[...]
>dbd_db2.c: At top level:
>dbd_db2.c:267: error: conflicting types for 'dbd_goto_row'
>/usr/include/dbi/dbd.h:41: note: previous declaration of 'dbd_goto_row' was 
>here
Hi,

this smells like a mismatch between your libdbi headers/libraries and the 
driver version you're trying to build. The dbd_goto_row() prototype and driver 
implementations were changed in early 2013. Make sure you have a matching 
libdbi 0.9 for your libdbi-drivers 0.9, or better yet, use the git versions of 
both if you're fiddling with experimental drivers.

regards,
Markus

-- 
Markus Hoenicka
http://www.mhoenicka.de
AQ score 38 
------------------------------------------------------------------------------
Want excitement?
Manually upgrade your production database.
When you want reliability, choose Perforce.
Perforce version control. Predictably reliable.
http://pubads.g.doubleclick.net/gampad/clk?id=157508191&iu=/4140/ostg.clktrk
_______________________________________________
libdbi-users mailing list
libdbi-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/libdbi-users

Reply via email to