Sounds like a plan, you'll have to figure out what to call the current implementation, I am bad with names. I'm working on a LibMesh-based implementation of one of my liquid crystal models (see my web page if you're interested). Once I have the basics of this worked out, I'll get started on implementing these changes you mentioned in the last email. > > >> would this be as simple as just adding an additional UnsteadySolver >> member to AdaptiveTimeSolver, so for example core_time_solver could >> be EulerSolver with theta=1 and (let's call it) aux_time_solver would >> then be another EulerSolver with theta=0. > > At this point we've differed enough from the original > AdaptiveTimeSolver design that I'd refactor the class tree. Maybe > make AdaptiveTimeSolver a branch class, with one leaf for the current > behavior (with what name?) and another for the new > PredictorCorrectorTimeSolver. Then you could rename core_time_solver > as corrector_time_solver and call aux_time_solver > predictor_time_solver, too. --
Nasser Mohieddin Abukhdeir Graduate Student (A.D. Rey Research Group) McGill University - Department of Chemical Engineering http://webpages.mcgill.ca/students/nabukh/web/ http://people.mcgill.ca/alejandro.rey/ ------------------------------------------------------------------------- This SF.net email is sponsored by: Microsoft Defy all challenges. Microsoft(R) Visual Studio 2008. http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/ _______________________________________________ Libmesh-users mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/libmesh-users
