Bug ID: 102374
           Summary: Find & Replace - Regular Expressions not recognized in
                    Replace field
           Product: LibreOffice
           Version: rc
          Hardware: x86-64 (AMD64)
                OS: Windows (All)
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: Writer

Is similar to 37494 and I agree with 38261 but this is specific to Writer and
using a regular expression in the Replace field.

I am trying to change the end of paragraph (reg exp $) with a tab (\t)  It
finds the end of paragraph just fine when I put the $ into the Find field and
have regular expression checkbox on.  I put \t into the Replace field and it
changes the end of paragraph to a slash and a t.    I have tried different
regular expressions in the Find field and all that I have tried seem to work. 
I have tried \t, \n, \u0009, \x09 in the Replace field and each time I get the
characters, as if the regular expression box was not checked.  I read another
post that said that Replace ALL worked when Replace did not.  I tried that also
but still got characters.

O a;sp tried copying a tab from somewhere else in the document and pasting it
into the Replace field.  Did not work.

Did finally find a workaround but it does not eliminate the bug.  Workaround:  
1.  Manually place a Tab in the document.
2.  Select and Copy that Tab.
3.  Select area to be searched.  
4.  open Find and Replace dialog box.  
5.  Type in $ in Find field.  
6.  Make sure Current Selection and Regular Expression boxes are checked.  
7.  Click FIND ALL.
8.  CTRL-V to paste the copied Tab into all the Find All places.

You are receiving this mail because:
You are the assignee for the bug.
Libreoffice-bugs mailing list

Reply via email to