https://bugs.documentfoundation.org/show_bug.cgi?id=103297

            Bug ID: 103297
           Summary: Macro fails when ODT document in Read-Only mode
           Product: LibreOffice
           Version: 5.0.5.2 release
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: Writer
          Assignee: libreoffice-bugs@lists.freedesktop.org
          Reporter: vic.orgos+bugslibreoff...@gmail.com

Description:
I have a macro does a google search for the word under the cursor that I
trigger with a keyboard shortcut. When the document is in Edit Mode it works
without fail but when the document is ODT format I DISABLE Edit Mode then it
fails with dialog box that says,

Libreoffice Error:
com.sun.star.uno.RuntimeExceptionScriptProtocolHandler::createScriptProvider(), 

Interestingly, if I open a .doc document and likewise DISABLE Edit Mode, I have
no problem running the macro.

the macro can be as simple as:

print "hello"

BUT if I run the macro from the Tools->Macros->Organize Macros->LibreOffice
Basic then it runs ok.

On ArchLinux running 5.1.5.2 it is the same BUT I can't even run the macro from
Tools->Macros...


Steps to Reproduce:
1. Open .doc document
2. Disable Edit Mode, Edit Menu->Edit Mode
3. Launch macro using keyboard shortcut

Actual Results:  
Error dialog appears.

Expected Results:
Macro to execute.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101
Firefox/49.0

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Libreoffice-bugs mailing list
Libreoffice-bugs@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libreoffice-bugs

Reply via email to