Bug ID: 103324
           Summary: user interface freezes on opening dialogs and context
           Product: LibreOffice
           Version: release
          Hardware: All
                OS: Linux (All)
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: UI

How to reproduce:

1. Open Libreoffice Calc (it opens relatively fast)
2. Enter few numbers in several cells (all is OK, formatting is OK)
3. Press CTRL+1 to open cell options (or right click).
4. The dialog shows after 5-10 seconds, but it is all BLACK, after 30-40
seconds it is finally drawn in an instant.
5. After the dialog is drawn completely, it is not a problem to change options
and switch between tabs.
6. After closing the dialog, to open the same dialog once again it will be a
couple of seconds faster, but still too slow.

The problem is not just with this dialog, but many dialogs (e.g. image
properties, character formatting, paragraph formatting, ...). Some open faster,
some slower.

This problem started to occur for the first time in the last month or so, but I
have not been paying too much attention because I didn't have much work to do
with office documents, just reading. 

So I am not able to remember and pinpoint what changed so that the situation
got worse.

I am using Archlinux on a Intel i5 with 4GB RAM, so it's not due to not having
enough resources. This happens even on empty documents with just 2 lines of

The problem affects all Libreoffice apps.

Writing pure text and reformatting text just by using the toolbar is OK.

I have tried several options to attempt and fix the problem, without success:
- deleted the .config profile
- reinstalled libreoffice (both -still and -fresh versions)
- reinstalled all libraries that libreoffice package depends on
- increased/decreased memory settings of libreoffice
- changed hardware acceleration and opengl options
- changed system themes and fonts
- have tried the most recent Zen and Mainline kernels available as arch
packages in order to try with different graphics driver versions

I don't have any other ideas what to try to solve this issue, but it is quite a
problem if you have to wait a minute on every picture you paste, just to be
able to rescale it or reposition it in the document.

I don't know how to debug it, but since I am an advanced linux user, any idea
what to do and try in order to be able to pinpoint why this happens is welcome.

You are receiving this mail because:
You are the assignee for the bug.
Libreoffice-bugs mailing list

Reply via email to