https://bugs.documentfoundation.org/show_bug.cgi?id=115582

            Bug ID: 115582
           Summary: VIEWING: Rotated Text in a Cell gets invisible
           Product: LibreOffice
           Version: 6.0.1.1 release
          Hardware: All
                OS: Windows (All)
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: Calc
          Assignee: libreoffice-bugs@lists.freedesktop.org
          Reporter: h...@brueckmann-gmbh.de

Description:
Rotated Text in Cell not shown (invisible) if angel is not 0,90,180,270 deg.
Example 98 deg. 
I have isolates the content.xml with one text in A1 where it is ok, and an
other Cell where it is not ok. Looks like a incompatibility between 5.x and 6.x
LO.

Steps to Reproduce:
1. WITH LO 5.3.5.2 Place some random Text. Do not take A1 take a place like B3.
2. rotate it by e.g. 82 deg.
3. looks fine, even if scrolling... Save it please.
4. Open the File wit an LO 6.0.X.X. The cell wil be shown a very short time an
then stay invisible, if you rotatet it to 90 deg. it is fine.
5. Take already rotated cell from an ods-file which is build by a LO 5.2.x.x
version by Copy & Paste then you get this issue too.


Actual Results:  
invisible Text


Expected Results:
visible, rotatet text in cell 


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Sometimes srcolling out of screen and back or resizing the cell shows text for
less a second. Look like a kind of repainting error.
Testet on Win 10 and Win 7 
Test on LO 6.0.0.3 and 6.0.1.1 failed
Test on LO 5.3.5.2 is ok
Here is a part of the content.xml where i presume the issue (locate for
rotation in this snippet) :
<style:style style:name="ce2" style:family="table-cell"
style:parent-style-name="Default">
            <style:table-cell-properties style:rotation-angle="79"/>
        </style:style>
        <style:style style:name="ce1" style:family="table-cell"
style:parent-style-name="Überschrift_20_1" style:data-style-name="N0">
            <style:table-cell-properties style:glyph-orientation-vertical="0"
style:cell-protect="protected" style:print-content="true"
style:text-align-source="fix" style:repeat-content="false"
fo:background-color="transparent" fo:wrap-option="wrap" fo:border="none"
style:direction="ltr" style:rotation-angle="82" style:rotation-align="none"
style:shrink-to-fit="false" style:vertical-align="middle"
loext:vertical-justify="auto"/>
            <style:paragraph-properties fo:text-align="center"
css3t:text-justify="auto" fo:margin-left="0mm" style:writing-mode="page"/>
            <style:text-properties style:use-window-font-color="true"
style:text-outline="false" style:text-line-through-style="none"
style:text-line-through-type="none" style:font-name="Arial" fo:font-size="10pt"
fo:font-style="normal" fo:text-shadow="none" style:text-underline-style="none"
fo:font-weight="bold" style:font-size-asian="10pt"
style:font-style-asian="normal" style:font-weight-asian="bold"
style:font-size-complex="10pt" style:font-style-complex="normal"
style:font-weight-complex="bold"/>
        </style:style>
    </office:automatic-styles>

OpenGL does not matter.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101
Firefox/58.0

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Libreoffice-bugs mailing list
Libreoffice-bugs@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libreoffice-bugs

Reply via email to