https://bugs.documentfoundation.org/show_bug.cgi?id=115590

            Bug ID: 115590
           Summary: Image position is wrong, if svg:x and svg:y does not
                    exist
           Product: LibreOffice
           Version: 6.1.0.0.alpha0+ Master
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: Writer
          Assignee: libreoffice-bugs@lists.freedesktop.org
          Reporter: rb.hensc...@t-online.de

Created attachment 139738
  --> https://bugs.documentfoundation.org/attachment.cgi?id=139738&action=edit
Anchor to page, from left and from top relative to page, version without svg:x
and svg:y

If Word rotates an image, then it writes it to an odt file in a way, that svg:x
and svg:y is missing. The translation before rotation and the translation after
rotation are different then.

LibreOffice gets the position of the rotated images wrong in these cases. Word
uses the rotation angle with wrong sign, but that does not influence the
position.

If you open the files with "_no_XY" and "_withXY" in Word, you can see that the
position of the rotated image (width=2cm height=6cm) is the same. If you open
the files in LibreOffice, you see, that the position of the rotated image in
the "_no_XY" files is wrong.

If svg:x or svg:y is not given, then it defaults to zero.

For a file produced be Word see attachment
https://bugs.documentfoundation.org/attachment.cgi?id=139695 from bug 115529.
In the files attached here, I have changed position and transformation
manually.

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Libreoffice-bugs mailing list
Libreoffice-bugs@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libreoffice-bugs

Reply via email to