https://bugs.documentfoundation.org/show_bug.cgi?id=116395

            Bug ID: 116395
           Summary: Run as vnd.libreoffice.command - OfficeURI is not "URL
                    decoded" and LO does not start
           Product: LibreOffice
           Version: 6.0.2.1 release
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: LibreOffice
          Assignee: libreoffice-bugs@lists.freedesktop.org
          Reporter: vladimir.do...@gmail.com

Description:
>From Internet Explorer new soffice.exe process is created with argument like:
"vnd.libreoffice.command:ofv|u|https://someweb.com:888/webdav/Test.odt";.

But from Chrome, argument is encoded like:
"vnd.libreoffice.command:ofv%7Cu%7Chttps://someweb.com:888/webdav/Test.odt";
and soffice.exe process ends immediately.

I think, that in cmdlineargs.cxx class
(libreoffice/core/tree/desktop/source/app/cmdlineargs.cxx) there should be some
URL decoding or simply replacing "%7C" with "|".

Conversion should be after this condition:

if (!isOfficeURI)
        return curEvt;

Steps to Reproduce:
Open document on WebDAV server from Chrome.

Actual Results:  
LibreOffice does not start.

Expected Results:
LibreOffice opens specified document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Verze: 6.0.2.1 (x64)
ID sestavení: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
Vlákna CPU: 4; OS: Windows 10.0; Vykreslování UI: výchozí; 
Národní prostředí: cs-CZ (cs_CZ); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101
Firefox/58.0

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Libreoffice-bugs mailing list
Libreoffice-bugs@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libreoffice-bugs

Reply via email to