https://bugs.documentfoundation.org/show_bug.cgi?id=118107

            Bug ID: 118107
           Summary: Assertion failure when playing a specific animation
                    coming from PP (with OpenGL)
           Product: LibreOffice
           Version: 6.2.0.0.alpha0+ Master
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: graphics stack
          Assignee: libreoffice-bugs@lists.freedesktop.org
          Reporter: ba...@caesar.elte.hu
            Blocks: 93529, 105537, 109362

Created attachment 142645
  --> https://bugs.documentfoundation.org/attachment.cgi?id=142645&action=edit
Backtrace

Use a debug build for repro.

- Enable OpenGL rendering.
- Add animation Fade in and Swivel (among Entrance / Special) to a piece of
text.
- Play the presentation.

=> When it finishes, there's the following assertion failure:
"Expression: !OpenGLHelper:isVCLOpenGLEnabled()"
assert(!OpenGLHelper::isVCLOpenGLEnabled());
https://opengrok.libreoffice.org/xref/core/vcl/source/outdev/bitmap.cxx

It seems like something wasn't implemented here, as several other animations
are unaffected.
Attaching backtrace.

Observed using LO 6.2 master build (565340d457f41197474a75ba1b036bdc3d569041) /
Windows 7.


Referenced Bugs:

https://bugs.documentfoundation.org/show_bug.cgi?id=93529
[Bug 93529] [META] VCL/OpenGL rendering tracker bug for 5.0+
https://bugs.documentfoundation.org/show_bug.cgi?id=105537
[Bug 105537] [META] Assertion failed crashes
https://bugs.documentfoundation.org/show_bug.cgi?id=109362
[Bug 109362] [META] Custom/object animation bugs and enhancements
-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Libreoffice-bugs mailing list
Libreoffice-bugs@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libreoffice-bugs

Reply via email to