Nice work!

Some random low priority comments:

In "Just walk the task list once per timeout"
The evaluate_entry label doesn't make the code any easier to read.

In "Reorganize Scheduler priority classes"
 (1) you haven't used a consistent mapping from old to new - sometimes LOW
maps to HIGH_IDLE, sometimes HIGHEST maps to HIGH_IDLE. Perhaps there is a
reason for this?
(2) I would call HIGH_IDLE, either PRE_RESIZE or BEFORE_RESIZE, because
it's not any kind of IDLE anymore. I would call DEFAULT_IDLE just IDLE.

In "Handle all main loop and task events"
    -    bProcessedEvent = bProcessedEvent || bScheduledEevent;
    +    bProcessedEvent |= bScheduledEevent;

In "Run Idle tasks immediatly"
It occurs to me that when we get an overload condition, it would be very
helpful to dump the names of the current events.
LibreOffice mailing list

Reply via email to