On Monday, September 19, 2016 12:43 CEST, Xisco Fauli
> - needAdvise: Used when help from developers in needed to confirm
> an UNCONFIRMED bug. Info:
> * Problem 1: Name is confusing.
> + Action: Rename it to 'needsConfirmationAdvise'
> * Problem 2: No New or resolved bugs should use it.
> + Action: Clean it up and create a new gardening task.
I think it would make sense to keep needAdvice keyword unrestricted from states.
- NEW doesn't always mean QA was able to reproduce the bug (if TRIAGED status
was in place, that would), see bug 101898 for example.
- if further details are posted in a bug report that require timely reaction,
but QA can't evaluate
them, advice from developers would be needed regardless of status. Again, a
bug 101821 (a question in this case, I haven't added the keyword, yet).
My suggestion is to name it something like needsDevAdvice, remove if advice was
was used unnecessarily or report got closed. It should still be used very
conservatively, of course.
> - needsDevEval: Should be used when a plausible easyhack lacks the
> code pointer, the difficulty, the topic or the skill and a developer > needs
> to provide the information missing.
> * Problem 1: It has been used to propose easyhacks over the > last
> + Action: Update the wiki accordingly:
What is the problem here? Is a proposed easy hack fundamentally different from
an easy hack that
lacks necessary details? Both are for the same people: the developers who have
the relevant pieces of code.
What is the workflow if I see a bug report that might be easy enough to be an
easy hack, but I have
zero knowledge about the underlying code? My ability to evaluate it stops
before the first action step
detailed in response to Problem 4. So, CC Jan and ask his opinion? Does any
keyword need to be set?
LibreOffice mailing list