Hi Miklos, Hi List,

I did some changes and passed the class instead of the instance but it does
not work either; looking at the print messages that I inserted it seems to
be never initialized.
I'll try to step through the TuesdayPrinter.py and see if that gives me any
insights; if you have any other ideas,I'd be happy to hear what else could
be wrong.


On Tue, Aug 8, 2017 at 9:30 AM, Miklos Vajna <vmik...@collabora.co.uk>

> Hi,
> On Tue, Aug 08, 2017 at 09:21:36AM +0200, jan d <dittrich.c....@gmail.com>
> wrote:
> > * I was unable to find the docuementation for
> > g_ImplementationHelper.addImplementation e.g. if it takes a class or an
> > instance. I tried with both (the inked example is an instance), non
> worked.
> https://gerrit.libreoffice.org/gitweb?p=sdk-examples.git;
> a=blob;f=TuesdayPython/TuesdayPrinter.py;hb=HEAD#l61
> I think this does something similar to your use-case, and there you can
> see that addImplementation() takes a class, not an instance.
> Regards,
> Miklos
LibreOffice mailing list

Reply via email to