On Tue, 16 Apr 2013, Peter Stuge wrote:

I strongly dislike the absolute disconnect between the extremely generic name libssh2_sftp_fsync() and the very opposite name fs...@openssh.com - unless libssh2 will in the future use a heuristic to determine which actual extension to use. I don't want that.

I do.

If there would appear another way to fsync in a future, we can introduce either a way for libssh2 to figure out by itself what method to use, or we provide an API for the application to select method.

At a minimum, I'd like a follow up patch which changes the API name to libssh2_sftp_fsync_openssh_com() or such..

Why do think this is necessary? I don't think we do a service to our users by exposing the underlying protocol naming in our function names. I also suspect that we won't be flooded by lots of other fsync variations either...

--

 / daniel.haxx.se
_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel

Reply via email to