Hi Anteja,

I’m not sure which platform that you using for emgd driver? EMGD driver only 
support on certains platform.
First, did you manage to emgd.ko loaded and get display up?

I think you can find the user guide for setup inside in the link below just now 
provided by Haihao.
http://edc.intel.com/Software/Downloads/EMGD/

To get libva to work, first you need get graphics driver loaded.
I’m not sure which emgd driver release support the libva through drm but only 
on certain platform only but it also require the emgd.ko to be loaded first as 
well.

Else you can go try on using install i915 graphics driver + Iibva + 
libva-intel-driver. Here is the build guide setup: 
https://01.org/linuxgraphics/documentation/build-guide-0 and installer package 
https://01.org/linuxgraphics/downloads

Thanks.
…siewhoon

From: Anteja Vuk Macek [mailto:anteja...@dolotron.com]
Sent: Wednesday, October 12, 2016 3:46 PM
To: Lim, Siew Hoon
Cc: Xiang, Haihao; libva@lists.freedesktop.org
Subject: Re: [Libva] va_getDriverName() returns -1

Hi,

Thanks Siew  for this steps, I try but error is same...
Is libva need x-server ?

Best regards,
Anteja


On Wed, Oct 12, 2016 at 9:36 AM, Lim, Siew Hoon 
<siew.hoon....@intel.com<mailto:siew.hoon....@intel.com>> wrote:
Hi Anteja,

The i965_drv_video.so may needs to be linked as emgd_drv_video.so  by the 
following step:
Step 1: cd /usr/lib/dri
Step 2: ln –sfv i965_drv_video.so emgd_drv_video.so

You can give a try on the step above.

Thank you.
….siewhoon

From: Libva 
[mailto:libva-boun...@lists.freedesktop.org<mailto:libva-boun...@lists.freedesktop.org>]
 On Behalf Of Anteja Vuk Macek
Sent: Wednesday, October 12, 2016 2:18 PM
To: Xiang, Haihao
Cc: libva@lists.freedesktop.org<mailto:libva@lists.freedesktop.org>
Subject: Re: [Libva] va_getDriverName() returns -1

Hi,

What I should I do to fix libva error ?

Best regards,
Anteja Vuk - Macek
Software Engineer

Dolotron d.o.o.
Ziskovec 141
HR-40000 Cakovec
Croatia
Tel: ++385 (40) 865 205<tel:%2B%2B385%20%2840%29%20865%20205>
Fax: ++385 (40) 865 732<tel:%2B%2B385%20%2840%29%20865%20732>
mailto: anteja...@dolotron.com<mailto:anteja...@dolotron.com>
_________________________________

On Wed, Oct 12, 2016 at 2:48 AM, Xiang, Haihao 
<haihao.xi...@intel.com<mailto:haihao.xi...@intel.com>> wrote:

I don't think libva-intel-driver can work with emgd. You should install
emgd backend vaapi driver:
http://edc.intel.com/Software/Downloads/EMGD/

I never tried emgd before, I'm sorry that I cannot provide more help
to you on this.

Thanks
Haihao

> Hi,
> But I install emgd driver 39.00, but i have problem with loading this
> module, you can see photo https://my.syncplicity.com/share/skvhanon0s
> xj5f8/IMG_20161011_104347 ;.
>
> Best regards,
>
> Anteja
>
> >
> > On Tue, Oct 11, 2016 at 11:00 AM, Anteja Vuk Macek <anteja.vm@dolot
<mailto:anteja.vm@dolot%0b>> > ron.com<http://ron.com>> wrote:
> > > Hi,
> > > I check if i915 is loaded, but i don't have similar message  ...
> > >
> > > only that ...
> > >
> > > [    3.529333] [drm] Initialized drm 1.1.0 20060810
> > >
> > > Best regards,
> > >
> > > Anteja
> > >
> > >
> > > On Tue, Oct 11, 2016 at 10:53 AM, Xiang, Haihao <haihao.xiang@int
<mailto:haihao.xiang@int%0b>> > > el.com<http://el.com>> wrote:
> > > >
> > > > Please check i915  is loaded or not.
> > > >
> > > > $>  dmeg | grep i915
> > > >
> > > > If i915 is loaded, you can see similar message below:
> > > >
> > > > [   10.943138] [drm] Initialized i915 1.6.0 20160919 for
> > > > 0000:00:02.0 on minor 0
> > > >
> > > >
> > > > Thanks
> > > > Haihao
> > > >
> > > >
> > > > > Hi
> > > > > >Could you post the output of 'lspci -nn'? I assumed you are
> > > > > using Intel Graphics.
> > > > >
> > > > > Yes I use intel graphic.  In attachment is output.txt ...
> > > > > I don't have that  /dev/dri/card0 ...
> > > > >
> > > > >
> > > > >
> > > > > Best regards,
> > > > >
> > > > > Anteja
> > > > >
> > > > >
> > > > > On Tue, Oct 11, 2016 at 8:17 AM, Xiang, Haihao <haihao.xiang@
<mailto:haihao.xiang@%0b>> > > > > intel.com<http://intel.com>> wrote:
> > > > > >
> > > > > > Could you post the output of 'lspci -nn'? I assumed you are
> > > > > > using Intel Graphics.
> > > > > >
> > > > > > You can try to  run vainfo without Xserver and Wayland.  If
> > > > > > you still get error, you should
> > > > > > check the following first:
> > > > > > 1> is there /dev/dri/card0. If not,  it means your GPU is
> > > > > > not supported by drm/i915.
> > > > > > 2> do you have permission to access /dev/dri/card0? Please
> > > > > > change the mode first if you haven't permission to access
> > > > > > /dev/dri/card0.
> > > > > >
> > > > > > Thanks
> > > > > > Haihao
> > > > > >
> > > > > > > Hi,
> > > > > > >
> > > > > > > I work with Fedora 18 ( KDE 32 bit ) ... I configure and
> > > > > > > install libva-1.5.0 on Fedora, use command vainfo and got
> > > > > > > error.
> > > > > > >
> > > > > > > [root@localhost intel-driver]# vainfo
> > > > > > > libva info: VA-API version 0.37.0
> > > > > > > libva info: va_getDriverName() returns -1
> > > > > > > libva error: va_getDriverName() failed with unknown libva
> > > > > > > error,driver_name=(null)
> > > > > > > vaInitialize failed with error code -1 (unknown libva
> > > > > > > error),exit
> > > > > > >
> > > > > > > I install before  :
> > > > > > > inputproto-2.3.1
> > > > > > > xorg-x11-drv-evdev-2.7.3-5
> > > > > > > libdrm-2.4.52
> > > > > > > mesa-10.2.1
> > > > > > > glu-9.0.0
> > > > > > > Also after installing libva I install intel-VA-driver-
> > > > > > > 1.5.0  ( git clone
> > > > > > > git://anongit.freedesktop.org/vaapi/intel-driver<http://anongit.freedesktop.org/vaapi/intel-driver>
> > > > > > >  )
> > > > > > >
> > > > > > > Configuration for libva and intel-VA-driver
> > > > > > > #./autogen.sh --prefix=/usr--enable -wayland
> > > > > > >
> > > > > > > Could somebody tell what I need to do for fix this error
> > > > > > > ?
> > > > > > >
> > > > > > > Best regards,
> > > > > > >
> > > > > > > TejaVM
> > > > > > > _______________________________________________
> > > > > > > Libva mailing list
> > > > > > > Libva@lists.freedesktop.org<mailto:Libva@lists.freedesktop.org>
> > > > > > > https://lists.freedesktop.org/mailman/listinfo/libva
> > >
> >


_______________________________________________
Libva mailing list
Libva@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/libva

Reply via email to