On 09/03/2014 06:15 PM, John Ferlan wrote:
> In order to support cpuset setting, introduce qemuSetupCgroupIOThreadsPin
> and qemuSetupCgroupForIOThreads to mimic the existing Vcpu API's.
> 
> These will support having an 'iotrhreadpin' element in the 'cpuset' in
> order to pin named IOThreads to specific CPU's. The IOThread pin names
> will follow the IOThread naming scheme starting at 1 (eg "iothread1")
> up through an including the def->iothreads value.
> 
> Signed-off-by: John Ferlan <jfer...@redhat.com>
> ---
>  src/qemu/qemu_cgroup.c | 104 
> +++++++++++++++++++++++++++++++++++++++++++++++++
>  src/qemu/qemu_cgroup.h |   5 +++
>  2 files changed, 109 insertions(+)
> 

>  
>  int
> +qemuSetupCgroupForIOThreads(virDomainObjPtr vm)
> +{

...

> +    }
> +
> +    for (i = 0; i < priv->niothreadpids; i++) {
> +        /* IOThreads are numbered 1..n, although the array is 0..n-1,
> +         * so we will laccount for that here

s/laccount/account/

> +         */
> +        if (virCgroupNewIOThread(priv->cgroup, i+1, true, &cgroup_iothread) 
> < 0)
> +            goto cleanup;
> +
> +        /* move the thread for iothread to sub dir */

Jan


Attachment: signature.asc
Description: OpenPGP digital signature

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to