Couple of these patches were requested in reviews to my previous namespace
patches, couple of them are my own idea. At the same time, 3 bugs are fixed:
1) qemuSecurity wrappers are preferred over virSecurityManager
2) corresponding /dev entry is not created when attaching vhost scsi device
3) corresponding /dev entry is not created when doing blockjobs

Michal Privoznik (11):
  qemuDomainAttachSCSIVHostDevice: Prefer qemuSecurity wrappers
  syntax-check: Enforce qemuSecurity
  qemuDomainAttachSCSIVHostDevice: manage /dev entry
  qemu_security: Kill code duplication
  qemu_security: Drop qemuSecuritySetRestoreAllLabelData struct
  qemu_domain: Don't pass virDomainDeviceDefPtr to ns helpers
  qemuDomainNamespaceSetupDisk: Drop useless @src variable
  qemuDomainNamespace{Setup,Teardown}Disk: Don't pass pointer to full
    disk
  qemuDomainDiskChainElement{Prepare,Revoke}: manage /dev entry
  qemu_security: Introduce ImageLabel APIs
  qemuDomainNamespaceSetupDisk: Simplify disk check

 cfg.mk                   |   8 ++
 src/qemu/qemu_domain.c   |  65 ++++++----------
 src/qemu/qemu_domain.h   |   4 +-
 src/qemu/qemu_driver.c   |   2 +-
 src/qemu/qemu_hotplug.c  |  20 +++--
 src/qemu/qemu_security.c | 189 ++++++++++++-----------------------------------
 src/qemu/qemu_security.h |   8 ++
 7 files changed, 102 insertions(+), 194 deletions(-)

-- 
2.11.0

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to