On 02/02/2018 06:11 AM, Jiri Denemark wrote:
> On Thu, Feb 01, 2018 at 18:24:33 -0500, John Ferlan wrote:
>> Convert the stats field in _qemuDomainJobInfo to be a union. This
>> will allow for the collection of various different types of stats
>> in the same field. While doing this, also change the name of the
>> field from @stats to @migStats to make it easier to find.
>> When starting the async job that will end up being used for stats,
>> set the @statsType value appropriately. The @mirrorStats are
>> special and are used with @migStats in order to generate the
>> returned job stats for a migration.
>> Using the NONE should avoid the possibility that some random
>> async job would try to return stats for migration even though
>> a migration is not in progress.
>> For now a migration and a save job will use the same statsType
>> Signed-off-by: John Ferlan <jfer...@redhat.com>
> You were too fast with v4. See
> https://www.redhat.com/archives/libvir-list/2018-February/msg00092.html
> Jirka

I guess I assumed you had stopped after the first 3 patches.  Perhaps
hazards of global engineering.

I can change the name from s.{mig|dump}Stats to stats.{mig|dump} and
remove the typecasts - perhaps just habit.  Guess I never realized or
thought about the _LAST thing - another one of those habitual things to
do when creating enum's.


libvir-list mailing list

Reply via email to