On 02/08/2018 08:26 AM, Daniel P. Berrangé wrote:
> On Thu, Feb 08, 2018 at 08:18:57AM -0500, John Ferlan wrote:
>>
>>
>> On 02/08/2018 05:16 AM, Daniel P. Berrangé wrote:
>>> On Tue, Feb 06, 2018 at 01:56:24PM -0500, John Ferlan wrote:
>>>> Hopefully I covered what's necessary... Essentially a bunch of
>>>> copying of existing examples...
>>>>
>>>> I haven't been able to actually build an RPM locally for a long
>>>> time, but this does work with make install at least (or at least
>>>> it worked in the environment I tried it on).
>>>
>>> What sort of problem are you having ?  The CI system is testing our
>>> RPM builds on Fedora so should work.
>>>
>>
>> Mostly bad and/or lazy (and/or annoyed) user on keyboard...  Never quite
>> seem to get the "correct packages" installed. Sometimes I get a list of
>> packages I'm missing from the make rpm command, while other times it's
>> just a failure and I'm left guessing and debugging. After a while I just
>> give up hoping that the CI system will do its thing...
> 
> You shouldn't have todo anything more then "dnf builddep libvirt" to
> get all the RPM pre-requisites installed. Now technically this will
> give you build deps suitable for the version of libvirt that's in
> Fedora, rather than git master, but we don't add new build-deps often
> enough for that to be a problem.
> 
> 

dnf builddep didn't find anything on one system, but still fails the
make rpm with the same uniconvertor issue.  Since it works elsewhere (CI
and my other host), I'm not going to jump into the rabbit hole.

John

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to