On 02/08/2018 02:19 PM, Laine Stump wrote:
> I've pushed the patches that passed review. These patches split a
> single patch from V1 into 2 patches, repost one patch that had no
> response, calls out a single line that had sneaked into one of the
> ACKed patches, and remove all tabs from perl and sh scripts.
> 
> Laine Stump (5):
>   parameterize filterref in generic_domain
>   default to no nwfilter in test domains
>   filter for proper IP address in tcpdump looking for broadcast packet
>   kill dhclient before attempting to change guest IP in no-ip-spoofing
>     test
>   untabify all perl and sh files
> 
>  lib/Sys/Virt/TCK.pm                              | 549 
> ++++++++++++-----------
>  lib/Sys/Virt/TCK/Capabilities.pm                 |  84 ++--
>  lib/Sys/Virt/TCK/DomainBuilder.pm                | 312 ++++++-------
>  lib/Sys/Virt/TCK/NetworkBuilder.pm               |  44 +-
>  lib/Sys/Virt/TCK/NetworkHelpers.pm               |   6 +-
>  lib/Sys/Virt/TCK/SELinux.pm                      |   6 +-
>  lib/Sys/Virt/TCK/StoragePoolBuilder.pm           |  40 +-
>  lib/Sys/Virt/TCK/StorageVolBuilder.pm            |  48 +-
>  lib/Sys/Virt/TCK/TAP/XMLFormatter.pm             |  18 +-
>  lib/Sys/Virt/TCK/TAP/XMLFormatterSession.pm      |  66 +--
>  scripts/nwfilter/100-ping-still-working.t        |   3 +-
>  scripts/nwfilter/210-no-mac-spoofing.t           |   3 +-
>  scripts/nwfilter/220-no-ip-spoofing.t            |   4 +-
>  scripts/nwfilter/230-no-mac-broadcast.t          |   5 +-
>  scripts/nwfilter/240-no-arp-spoofing.t           |   3 +-
>  scripts/nwfilter/300-vsitype.t                   |   2 +-
>  scripts/nwfilter/concurrency/chg-vm-filter.sh    |  18 +-
>  scripts/nwfilter/concurrency/start-destroy-vm.sh |  20 +-
>  scripts/nwfilter/nwfilter2vmtest.sh              |  42 +-
>  19 files changed, 641 insertions(+), 632 deletions(-)
> 

FWIW: This and the patches already pushed works great in my test
environment with the onlist nwfilter patches also applied. Very
entertaining and educational to watch with --verbose flag set too.

The only one that I'm not sure how to configure to make sure it runs is
the 300-vsitype.t - here's the tail end of my output:

/usr/share/libvirt-tck/tests/nwfilter/300-vsitype.t .............
1..0 # SKIP no host net device configured
skipped: no host net device configured
All tests successful.
Files=8, Tests=1272, 376 wallclock secs ( 0.59 usr  0.06 sys + 36.76
cusr 54.68 csys = 92.09 CPU)
Result: PASS


John

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to