The Net::OpenSSH module requires IO::Pty if password authentication
will be used, but The Fedora Net::OpenSSH maintainers don't want to
put anything stronger that "Suggests: perl(IO::Pty)" in their
specfile, which unfortunately does absolutely nothing. (see ). The alternate
solution is for perl-Sys-Virt-TCK.spec to require perl(IO::Pty), and
that's what this patch does.

Signed-off-by: Laine Stump <>
 perl-Sys-Virt-TCK.spec.PL | 1 +
 1 file changed, 1 insertion(+)

diff --git a/perl-Sys-Virt-TCK.spec.PL b/perl-Sys-Virt-TCK.spec.PL
index 1534854..7c83be9 100644
--- a/perl-Sys-Virt-TCK.spec.PL
+++ b/perl-Sys-Virt-TCK.spec.PL
@@ -74,6 +74,7 @@ Requires: perl(TAP::Formatter::HTML)
 Requires: perl(TAP::Formatter::JUnit)
 Requires: perl(TAP::Harness::Archive)
 Requires: perl(Net::OpenSSH)
+Requires: perl(IO::Pty)
 Requires: /usr/bin/mkisofs
 BuildArchitectures: noarch

libvir-list mailing list

Reply via email to