On Thu, Feb 22, 2018 at 05:02:15PM -0500, Cole Robinson wrote:
> I'm confused why this is still failing. I set up a debian9 vm,
> reproduced the issue which fails about 50% of the time, and verified
> that commit 059fb7d0ba1d414db3db485903972b48c1dda629 fixes it
> completely, or at least I can't reproduce. But this is still failing.

> 
> Weirdly though
> 
> On 02/22/2018 04:18 PM, c...@centos.org wrote:
> > See 
> > <https://ci.centos.org/job/virt-manager-master-py3-check/systems=libvirt-debian-9/14/display/redirect>
> > 
> > ------------------------------------------
> > Started by upstream project "virt-manager-master-py3-check" build number 14
> > originally caused by:
> >  Started by upstream project "virt-manager-master-py3-build" build number 14
> >  originally caused by:
> >   Started by an SCM change
> > [EnvInject] - Loading node environment variables.
> > Building remotely on libvirt-debian-9 (libvirt) in workspace 
> > <https://ci.centos.org/job/virt-manager-master-py3-check/systems=libvirt-debian-9/ws/>
> > [virt-manager-master] $ /bin/sh -xe /tmp/jenkins3940620727838286920.sh
> > + MAKE=make
> > + uname
> > + unamestr=Linux
> > + [ Linux = FreeBSD ]
> > + export 
> > PATH=/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
> > + export 
> > PYTHONPATH=/home/jenkins/build/libvirt/lib/python3.4/site-packages:/home/jenkins/build/libvirt/lib64/python3.4/site-packages:/home/jenkins/build/libvirt/lib/python3.5/site-packages:/home/jenkins/build/libvirt/lib64/python3.5/site-packages:/home/jenkins/build/libvirt/lib/python3.6/site-packages:/home/jenkins/build/libvirt/lib64/python3.6/site-packages:/home/jenkins/build/libvirt/lib/python3.7/site-packages:/home/jenkins/build/libvirt/lib64/python3.7/site-packages
> > + python3 ./setup.py test
> > running test
> > ..............................................................................................................................F...............................................................................................................................................s........................................................................................................................................................................
> > ======================================================================
> > FAIL: testCLI0002virt_install_singleton_config_2 (tests.clitest.CLITests)
> > ----------------------------------------------------------------------
> > Traceback (most recent call last):
> >   File 
> > "<https://ci.centos.org/job/virt-manager-master-py3-check/systems=libvirt-debian-9/ws/tests/clitest.py";,>
> >  line 1110, in <lambda>
> >     return lambda s: cmdtemplate(s, cmd)
> >   File 
> > "<https://ci.centos.org/job/virt-manager-master-py3-check/systems=libvirt-debian-9/ws/tests/clitest.py";,>
> >  line 1109, in cmdtemplate
> >     _cmdobj.run(self)
> >   File 
> > "<https://ci.centos.org/job/virt-manager-master-py3-check/systems=libvirt-debian-9/ws/tests/clitest.py";,>
> >  line 277, in run
> >     tests.fail(err)
> 
> These line numbers don't match up with the line numbers in virt-manager
> git master. Is there some chance it's using old code? it certainly seems
> to be detecting new commits coming in which trigger builds, but I thing
> something weird is going on here

Yeah its very odd. I've blown away the git checkout and it succeeed on
rebuild, so lets see if it stays fixed...


Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to