On Mon, Apr 16, 2018 at 07:53:42AM -0400, John Ferlan wrote:
> On 04/13/2018 10:47 AM, Michal Privoznik wrote:
> > In next patches this name will be needed for a different memeber.
> > Also, it makes sense to rename the variable because it does not
> > contain reference to parent device, just its name.
> > Signed-off-by: Michal Privoznik <mpriv...@redhat.com>
> > ---
> > src/conf/virnodedeviceobj.c | 2 +-
> > src/datatypes.c | 2 +-
> > src/datatypes.h | 2 +-
> > src/libvirt-nodedev.c | 6 +++---
> > src/node_device/node_device_driver.c | 4 ++--
> > src/test/test_driver.c | 6 +++---
> > 6 files changed, 11 insertions(+), 11 deletions(-)
> FWIW: Not sure about changing the accessor's name too - that would mean
> the API name doesn't match (virNodeDeviceGetParent which could lead to
> other problems with automatic code generation).
Oh, is that so?! I missed this fact, sorry for the noise then. Nevertheless,
it's sad we've such a mistake.
libvir-list mailing list