The first two patches tune up the XML elements to use camelCase
instead of dashes as the word separators.

Hopefully our QEMU capability probing is right and we can fix error
reporting in patch 3.

The rest are minor cleanups and renames to use SEV instead of Sev
in internal identifier names.

I did not touch virNodeGetSevInfoEnsureACL - not sure if it's all right
since the public API uses SEV.

Ján Tomko (10):
  domaincaps: rename reduced-phys-bits to reducedPhysBits
  conf: prefer camelCase for launchSecurity
  qemu: fail if virQEMUCapsProbeQMPSEVCapabilities fails
  remove virQEMUCapsSetSEVCapabilities
  qemuDomainGetSEVMeasurement: fix possible leak
  rename qemuBuildSevCreateFile to qemuProcessSEVCreateFile
  qemuProcessSEVCreateFile: use a cleanup label
  Rename virDomainSevDefPtr to virDomainSEVDefPtr
  rename more Sev functions to SEV
  qemuMonitorJSONGetSEVCapabilities: remove redundant whitespace

 docs/formatdomain.html.in                          | 22 +++++++--------
 docs/formatdomaincaps.html.in                      |  2 +-
 docs/schemas/domaincaps.rng                        |  2 +-
 docs/schemas/domaincommon.rng                      | 10 +++----
 src/conf/domain_capabilities.c                     |  2 +-
 src/conf/domain_conf.c                             | 32 +++++++++++-----------
 src/conf/domain_conf.h                             |  8 +++---
 src/qemu/qemu_capabilities.c                       | 16 ++---------
 src/qemu/qemu_command.c                            |  6 ++--
 src/qemu/qemu_driver.c                             |  2 +-
 src/qemu/qemu_monitor_json.c                       |  1 -
 src/qemu/qemu_process.c                            | 26 ++++++++----------
 tests/genericxml2xmlindata/launch-security-sev.xml |  8 +++---
 tests/qemuxml2argvdata/launch-security-sev.xml     |  8 +++---
 14 files changed, 66 insertions(+), 79 deletions(-)

-- 
2.16.1

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list

Reply via email to