I'm trying to using virsh update-device to update the CDROM from type='file'
to ceph rbd iso with type='network'.
But I always get
error: Failed to update device from disk
error: internal error: unable to execute QEMU command 'change': error
connecting: Operation not supported
I'm using libvirt-libs-3.10.0-1.el7.x86_64 with centos7.4
my original cdrom xml:
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <target dev='hdc' bus='ide' tray='open'/>
      <alias name='ide0-1-0'/>
      <address type='drive' controller='0' bus='1' target='0' unit='0'/>
my rbd cdrom xml:
<disk device="cdrom" type="network">
  <driver name='qemu' type='raw'/>
  <auth username="zstack">
      <secret type="ceph" uuid="efd3eb93-014f-4a0f-ba1f-84d7e70c9a89"/>
    <host name="" port="6789"/>
  <target bus="ide" dev="hdc"/>

>From the libvirtd.log, I got
Send command
which seems it pass the auth_support=none to the qemu, while I'm using an
authentication ceph, it should use auth_support=cephx instead.

I also tried to boot the VM with rbd iso and then update-device to another
rbd iso, but got no luck with the same error. 
I have succeeded to update-device with libvirt-1.3.3,

I noticed that it depends on the orig_disk->privData->secinfo, and in my
environment it will be null which leads to the auth_support=none.
So I'm wondering if this is a bug or I did something wrong with my
configuration. Thanks in advance,

Best Regards,

libvirt-users mailing list

Reply via email to