Hey folks, I'm trying to build the lift sources.  It mostly works, but
I see more errors and warnings than I expected.  I'm wondering if my
configuration is set up correctly.  Or do you see errors/warnings
too?  Thx.

mvn jetty:run in liftweb/sites/example seems to work.

I've tried mvn clean, and deleting my .m2/repository.

I tried mvn jetty:run in hellodarwin and got:

ERROR - Failed to Boot
net.liftweb.sitemap.SiteMapException: Location Hello1.1 defined twice
Loc(Hello1.1, <function>, LinkText(<function>), List()) and Loc
(Hello1.1, <function>, LinkText(<function>), List())
        at net.liftweb.sitemap.SiteMap.addLoc(SiteMap.scala:36)
---


Here are a few of the errors/warning when I try mvn install:

Tests in error:
  wiki edit HomePage should not have HomePage content define
  wiki edit HomePage should allow edition of HomePage
Tests run: 2, Failures: 0, Errors: 2, Skipped: 0
--

[INFO] suggestion: remove the scalaVersion from pom.xml
[ERROR] /home/lee/tools/liftweb/lift-widgets/src/main/scala
--

[WARNING] .../target/classes/toserve/tablesorter/
jquery.tablesorter.js:line -1:column -1:Try to use a single 'var'
statement per scope.
--

[WARNING] /home/lee/tools/liftweb/sites/hellolift/src/main/scala/com/
hellolift/comet/DynamicBlogView.scala:35: warning: match is not
exhaustive!
[WARNING] missing combination          Empty
[WARNING] missing combination        Failure
[WARNING]
[WARNING]     name match {
[WARNING]     ^
[WARNING] warning: there were unchecked warnings; re-run with -
unchecked for details
[WARNING] two warnings found
--



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Lift" group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to