Well if users would, for at least one release, explicitly say which time 
library they want to use, this kind of bug would not occur.
It's not 'jt' per se; rather, as Derek said, it's having names that indicate 
the implementation detail rather than simply what it does. It makes code less 
We required everyone to update their imports for Box and actors. I think your 
argument is that requiring such changes should only be done when there is a big 
enough gain. So the disagreement seems to be whether allowing people to use 
JodaTime code that's as readable as java.util time is important enough. Or 
whether names like 'jtNow' are less readable.
Another point. If JDK 7 time is not 100% compatible with JodaTime, if we take 
TimeHelpers out of Helpers, having all 3 play together nicely is 
straightforward. On the other hand, if we try to squeeze in new names, we will 
have to add even more of them.
And say some company wants to add their own time API.

David Pollak<feeder.of.the.be...@gmail.com> wrote:

On Sat, Oct 24, 2009 at 3:05 AM, Jeppe Nejsum Madsen <je...@ingolfs.dk>wrote:

> Derek Chen-Becker <dchenbec...@gmail.com> writes:
> [...]
> >  It's entirely subjective, but I just strongly dislike the idea of
> > using method names like jtNow, etc.
> I couldn't agree more....code just doesn't read nice anymore.

I'm cool with other names, but, and this is a huge *BUT*...

having two methods that have different return signatures is a huge source of
bugs.  We saw this when we changed some of the S methods to return
Box[String] rather than String.  There were hundreds of subtle errors.

I'm happy to deprecate now and have goodNow (returns JodaTime) and evilNow
(returns java.util.Date), but I am 100% against changing a return signature.

I am sorry that my position is making folks unhappy, especially Derek who
works hard and does a great job.



> /Jeppe
> >

Lift, the simply functional web framework http://liftweb.net
Beginning Scala http://www.apress.com/book/view/1430219890
Follow me: http://twitter.com/dpp
Surf the harmonics

You received this message because you are subscribed to the Google Groups 
"Lift" group.
To post to this group, send email to liftweb@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to