Indeed, with issue [4797](#4797) and several earlier parser changes, the first 
of these options (`violin.1`) does work, although in a slightly different way 
by creating an alist. (Which may have side effects, and the corresponding 
`\violin.1` cannot be used in all situations where `\violin` can be used.)
Still, I think this issue is reasonably covered by that, and the topic is on 
the TODO-list for the mythical GLISS, which might still happen one day.
So I vote for closing the issue.


---

** [issues:#1670] Allow numbers in variable names: violin.1.mvt.2 = c'**

**Status:** 
**Created:** Fri May 27, 2011 11:59 AM UTC by Anonymous
**Last Updated:** Mon Oct 29, 2012 11:28 PM UTC
**Owner:** nobody


*Originally created by:* *anonymous

*Originally created by:* 
[k-ohara5...@oco.net](http://code.google.com/u/110197288862747384800/)

Users often request variable names including numbers or underscores
\([http://lists.gnu.org/archive/html/lilypond-user/2011-05/msg00177.html](http://lists.gnu.org/archive/html/lilypond-user/2011-05/msg00177.html)\)

1\) It is not too hard for the lexer, which breaks input into tokens, to accept 
backslashed variable names with various characters.
\([http://lists.gnu.org/archive/html/lilypond-devel/2004-03/msg00124.html](http://lists.gnu.org/archive/html/lilypond-devel/2004-03/msg00124.html)\)

We could then use something like:
   "violin1" = \{ c d e \}
   \new Staff \violin1
but what do we really want to allow in variable names?  

I don't think underscores are a good idea, because both human and computer 
could be confused:
 c^\slide\_1 % is that slide on the first finger or did somebody define 
\slide\_1 ?

Ending in a number would require we enforce the space after a command \(and 
convert-ly old scores\) for cases like  \times2/3\{c d e\}


2\) There is considerable difficulty in telling Lilypond to be ready for the 
definition of a variable that looks somewhat like, because the grammar allows 
un-braced music expressions and user-defined functions.
  \mySpecialAfterGrace do1 re2 mo3 = fa2

Lily would need to know how many arguments \MySpecialAfterGrace takes to know 
whether she needs to look up 'mo' as the name of a pitch in some language.
Either that, or tentatively read through to the '=' and then back up when she 
realized 'mo' was not a mis-typed note name.

\(2\) might be impossible, but maybe users want \violin1 badly enough to use 
quotes around it in the definition, as I did above?


---

Sent from sourceforge.net because testlilyissues-a...@lists.sourceforge.net is 
subscribed to https://sourceforge.net/p/testlilyissues/issues/

To unsubscribe from further messages, a project admin can change settings at 
https://sourceforge.net/p/testlilyissues/admin/issues/options.  Or, if this is 
a mailing list, you can unsubscribe from the mailing list.
------------------------------------------------------------------------------
_______________________________________________
Testlilyissues-auto mailing list
testlilyissues-a...@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/testlilyissues-auto

Reply via email to