Il giorno sab 15 lug 2017 alle 20:43, Paul <> ha scritto:
On 07/14/2017 05:52 AM, Federico Bruni wrote:
Hi Federico,

This looks great! I downloaded the one for linux (I'm on Ubuntu 16.04 LTS) and gave it a try. I ran into a few things but got it working and successfully built LilyPond in the container. Details below.

One issue was that I had systemd installed, but not systemd-container, so I had to install that. So maybe we should add that to the dependencies in the instructions?

$ sudo systemd-nspawn -bD lilydevos-0.1
sudo: unable to resolve host t440s
sudo: systemd-nspawn: command not found

$ systemd-nspawn --help
The program 'systemd-nspawn' is currently not installed. You can install it by typing:
sudo apt install systemd-container

Thanks Paul, I'll update the README.
I thought it was included in the systemd package, but it's actually separate.
Same package name in Fedora:

$ dnf provides /usr/bin/systemd-nspawn
Last metadata expiration check: 5 days, 0:34:02 ago on Wed Jul 12 09:42:26 2017.
systemd-container-233-6.fc26.x86_64 : Tools for containers and VMs
Repo        : @System

After that, things worked, although I saw some "Failed to..." messages, not sure if they are a problem or not:

$ sudo systemd-nspawn -bD lilydevos-0.1
sudo: unable to resolve host t440s

This is not causing any problem, right?
Anyway, here you can find some hints on how to fix it:

Spawning container lilydevos-0.1 on /home/paul/lilypond-world/LilyDevOS/lilydevos-0.1.
Press ^] three times within 1s to kill container.
Failed to create directory /home/paul/lilypond-world/LilyDevOS/lilydevos-0.1/sys/fs/selinux: Read-only file system Failed to create directory /home/paul/lilypond-world/LilyDevOS/lilydevos-0.1/sys/fs/selinux: Read-only file system

I think you can safely ignore it.

This may happen when selinux is disabled, according to this:

But I have selinux disabled and I'm not getting those messages...

# sestatus
SELinux status:                 disabled

Next I found that the uid for the dev user in the container was not the same as my host user uid, so I wasn't able to access the files from the host user account. But I was able to use the instructions in this blog post to change the dev user uid and that fixed it:


And I was able to successfully build lilypond in the container. (Look mom, no VM!)

So this is really nice. I can edit files using my usual desktop environment and text editor, then just do git and git-cl via the command line in the container.

One other minor thing is I noticed that trying to run gitk in the container doesn't work:

$ gitk
application-specific initialization failed: no display name and no $DISPLAY environment variable Error in startup script: no display name and no $DISPLAY environment variable
    while executing
"load /usr/lib64/ Tk"
    ("package ifneeded Tk 8.6.6" script)
    invoked from within
"package require Tk"
    (file "/usr/bin/gitk" line 10)

But, it works to run it from a terminal in the host account.

It can work also from the guest if you use the correct DISPLAY environment variable.
Find it in your host with this command:

$ echo $DISPLAY

Then launch gitk from the container with:

$ DISPLAY=:0 gitk

Also, the authentication in git-cl opens a web page in a browser so I'm not sure how that will work from the container?

Good point. I don't think that there's even any browser in the container now. Perhaps I may install a text browser and set the BROWSER environment variable.
I have a small patch to send, I'll let you know how it works.

Anyway, thanks for your work on this! It will be really nice not to have the overhead of a VM.

I'm glad that it's useful. Thanks for the feeedback!

lilypond-devel mailing list

Reply via email to