On 4/11/2018 3:48 PM, Peter Engelbert wrote:
In the meantime, I also noticed that for some reason Lilypond 2.18.2 is not
in the Debian Stretch (9) repository for ARM, but it IS in the Debian
Jessie (8) repository. So I was able to install 2.18.2 for the raspberry pi
by adding the Jessie repository. Is it’s absence in the Stretch repository
an oversight, or is there some reason for it?


LilyPond depends on Guile 1.8; more recent versions are incompatible so far. Newer Debian versions have removed Guile 1.8. Here are a few threads from the lilypond-devel list that may be of interest.

LilyPond in Debian
<https://lists.gnu.org/archive/html/lilypond-devel/2017-09/msg00042.html>

compiling lilypond in debian stretch with self-compiled guile-1.8
<https://lists.gnu.org/archive/html/lilypond-devel/2017-10/msg00098.html>
--
Karlin High
Missouri, USA

_______________________________________________
lilypond-devel mailing list
lilypond-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-devel

Reply via email to