Jonas Hahnfeld <hah...@hahnjo.de> writes:

> Am Freitag, den 08.11.2019, 22:21 +0100 schrieb David Kastrup:
>> Thomas Morley <thomasmorle...@gmail.com> writes:
>> > Am Fr., 8. Nov. 2019 um 16:34 Uhr schrieb David Kastrup <d...@gnu.org>:
>> > > I got it now.  I used to do
>> > > ./configure --enable-checking 
>> > > GUILE_CONFIG=/usr/local/tmp/guile-1.8/bin/guile-config
>> > > but that appears to mess up the setting of GUILE, so I need to do
>> > > ./configure
>> > > --enable-checkingGUILE_CONFIG=/usr/local/tmp/guile-1.8/bin/guile-configGUILE=/usr/bin/guile
>> > > Apparently using GUILE_CONFIG precludes or sabotages the checks for 
>> > > GUILE ?
>> > 
>> > I made the experience that I need to set
>> > GUILE_CONFIG=... *and*GUILE=... if I want a build which uses a not
>> > system-wide installedguile-version.
>> 
>> But I have a system-wide installed guile version at /usr/bin/guile
>> .It's a Guile-2.0 but that's fine for scripts.  So there really is
>> nogood reason that it isn't found.
>
> AFAICS configure requires a guile executable between versions 1.8.2 to
> 1.9.0 (see configure.ac, line 309), unless you pass --enable-guile2
> which is off by default.

That would seem a mistake.  LilyPond works perfectly well with a Guile-2
executable.  It's the Guile-1.8 development libraries that are needed
for compilation into the LilyPond binary, but the scripts are fine using
later binaries of Guile.

-- 
David Kastrup

Reply via email to