Am Samstag, den 09.11.2019, 12:55 +0100 schrieb David Kastrup:
> Jonas Hahnfeld <hah...@hahnjo.de> writes:
> > Am Freitag, den 08.11.2019, 22:21 +0100 schrieb David Kastrup:
> > > Thomas Morley <thomasmorle...@gmail.com> writes:
> > > > Am Fr., 8. Nov. 2019 um 16:34 Uhr schrieb David Kastrup <d...@gnu.org>:
> > > > > I got it now.  I used to do./configure --enable-checking 
> > > > > GUILE_CONFIG=/usr/local/tmp/guile-1.8/bin/guile-configbut that 
> > > > > appears to mess up the setting of GUILE, so I need to 
> > > > > do./configure--enable-checkingGUILE_CONFIG=/usr/local/tmp/guile-1.8/bin/guile-configGUILE=/usr/bin/guileApparently
> > > > >  using GUILE_CONFIG precludes or sabotages the checks for GUILE ?
> > > > 
> > > > I made the experience that I need to setGUILE_CONFIG=... *and*GUILE=... 
> > > > if I want a build which uses a notsystem-wide installedguile-version.
> > > 
> > > But I have a system-wide installed guile version at /usr/bin/guile.It's a 
> > > Guile-2.0 but that's fine for scripts.  So there really isnogood reason 
> > > that it isn't found.
> > 
> > AFAICS configure requires a guile executable between versions 1.8.2 to1.9.0 
> > (see configure.ac, line 309), unless you pass --enable-guile2which is off 
> > by default.
> 
> That would seem a mistake.  LilyPond works perfectly well with a 
> Guile-2executable.  It's the Guile-1.8 development libraries that are 
> neededfor compilation into the LilyPond binary, but the scripts are fine 
> usinglater binaries of Guile.

That is $ git log -p -n1 e9ae1cb3b093498ccb9d5f7348c755a3243bbccc -- 
configure.accommit e9ae1cb3b093498ccb9d5f7348c755a3243bbcccAuthor: Thomas 
Morley <thomasmorle...@gmail.com>Date:   Sun Mar 19 14:29:04 2017 +0100
    Issue 5108 Let configure find all needed files with guile-2.2        in 
configure.ac    Adds support for STEPMAKE_GUILE    Update guile-versions for 
STEPMAKE_GUILE and STEPMAKE_GUILE_DEVEL        in aclocal.m4    update the list 
to search for guile-config        Many thanks to Antonio Ospite
diff --git a/configure.ac b/configure.acindex d77ea15881..8f2f61abf8 100644--- 
a/configure.ac+++ b/configure.ac@@ -181,7 +181,7 @@ STEPMAKE_TEXMF(REQUIRED) 
STEPMAKE_TEXMF_DIRS(REQUIRED) if test "$GUILEv2" = "yes" then-    
STEPMAKE_GUILE_DEVEL(REQUIRED, 2.0.7, 2.2.0)+    STEPMAKE_GUILE_DEVEL(REQUIRED, 
2.0.7, 2.3.0) else     STEPMAKE_GUILE_DEVEL(REQUIRED, 1.8.2, 1.9.0) fi@@ -267,7 
+267,12 @@ STEPMAKE_FREETYPE2(freetype2, REQUIRED, 2.1.10) STEPMAKE_WINDOWS  # 
guile executable for some scripts-STEPMAKE_GUILE(OPTIONAL, 1.8.2, 1.9.0)+if 
test "$GUILEv2" = "yes"+then+    STEPMAKE_GUILE(OPTIONAL, 2.0.7, 2.3.0)+else+   
 STEPMAKE_GUILE(OPTIONAL, 1.8.2, 1.9.0)+fi  # perl for help2man and for 
mf2pt1.pl STEPMAKE_PERL(REQUIRED)
but before this commit, it would just always require Guile 1.8.2 to 1.9.0. I've 
no experience with using guile-2.0 or guile-2.2 for the scripts, but if you 
post a patch I can give it a try (Arch Linux bundles all three versions).
Just wondering if it's wise to use a different version of Guile for the scripts 
than the libraries...

Jonas

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to