> Hi MJ,
> 
> > Thanks for your suggestion, it improves matters a lot, but there are 
> > still *MANY* (different kinds) errors. The complete output is here:
> > 
> > http://codepad.org/Qc93Rvyu
> 
> I see lots of errors. I then had a look at the Messiah ly files and saw most
> of
> them have no \version in them, which is really bad.
> Some have and that's either 2.11.x or 2.13.x (probably not a complete list).
> 
> > Are there some basic settings/things that would perhaps help..?
> 
> I would throw convert-ly at them. For that to work you'd need to add \version
> statements (or that's my understanding). Quite a task.

Forget that - the --from=versionnumer parameter of convertly takes care of that.

> After that and assuming you're on Linux you could something like
>   find . -name "*.*ly" -exec convert-ly --from=2.11 {} ";"
> (I'm not on my linux/LP machine just now, can't test, but the above should
> give
> you the idea)
> 
> Or manually go through all directories and issue something like
>   convert-ly -e --from=2.11 *.*ly
> You may try 2.13 or something else as well.
> 
> This should fix many and if you're lucky most of the errors.
> 
> Kind regards,
> Michael
> --
> Michael Gerdau       email: m...@qata.de
> GPG-keys available on request or at public keyserver
> 
> _______________________________________________
> lilypond-user mailing list
> lilypond-user@gnu.org
> https://lists.gnu.org/mailman/listinfo/lilypond-user
> 
--
Michael Gerdau       email: m...@qata.de
GPG-keys available on request or at public keyserver

_______________________________________________
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user

Reply via email to