SK <> writes:

> Hello,
> I found very strange behaviour of \chords when used together with
> \numericTimeSignature. Check the following code:
> \new Score {
> <<
> \chords { c1 g c g }
> \relative c' { \numericTimeSignature c4-1 c c2 d4 d d2 e4 e e c e2 d \bar
> "|." }
> }
> When running it on LilyBin, it compiles correctly with the latest stable
> version, but with latest unstable, it shows no notes or staff, but only a
> line of chords.

That is expected.  You never create any context but a Chords context,
and Chords have become aliased to Staff (in order to avoid spurious
creation of Staffs where not desired) and thus a sufficient target for

> I tried to move the \numericTimeSignature to different places, but
> neither worked: Sometimes I got the chords below my staff, sometimes I
> got an extra staff with just the timeSignature - I think the place
> where I have it should work.  Are there any changes in the unstable
> version to this part, or is it simply a bug?

If you want a Staff, write \new Staff .  It is as simple as that.  Like

\new Staff \relative c' { \numericTimeSignature ...

David Kastrup
My replies have a tendency to cause friction.  To help mitigating
damage, feel free to forward problematic posts to me adding a subject
like "timeout 1d" (for a suggested timeout of 1 day) or "offensive".

Reply via email to