On Fri, 28 Dec 2001, Tzafrir Cohen wrote:

> I'm generally quite satisfied with this one (even though I have some
> problems when trying to build it on other platforms, mainly with
> refreshd, I can live with that)
> So I'd like to hear some success stories, and then get 1.0 out.

i am trying it out here now (redhat 6.2 with various manual changes).

first, some output i see in the configure script's output on the screen:

checking for gnome - version >= 1.0... ./configure: test: integer
expression expected after -lt

there's some problem with the test there. i see this again later when
checking for another component. running with '-x' reveals the problem is
with 'gnome_wanted_micro_version' being set to an empty string, rather
then a number, at line 835, and thus the 'test' on line 2581 yields a
syntactic error.

the other component with a problem is 'r2llib'. on line 1014. what happend
is that 'r2llib-config --version' here returns '0.32', while the script
seems to expect '0.3.2', and this the script sets
r2llib_config_micro_version to an empty string. please note that i have a
copy of r2llib installed in the system, and i also get a warning about it:

configure: warning: Using system version of r2llib from

libdockapp was detected properly. i'll run a test without it in a minute,
to see if it works.

another thing - when i ran 'make install', then after the installation, an
'install' script is being built - either it should be built _before_
installing the files, or it shouldn't be built at all - but certainly not
be built as the last operation of 'make install'.

now, running biditext causes applications to crash during startup (tried
with 'netscape' [which crashed] and with 'gnome-terminal'. gnome-terminal
itself didn't crash, but a lynx ran under it crashed with a bus error).

i decided perhaps my local copy of r2llib is at fault, so i manually
removed it (removing all files from /usr/local/lib/libr2l* and
/usr/loacl/bin/r2l*, including the insalled r2l applets). when i did that,
the configure script barfed that i don't have a version of 'r2llib', and
then barfed that i don't have the right version - it shouldn't go checking
the version if it doesn't find the library. nontheless, it ran to the end.

the 'r2l' program was not installed in the system - which is not good,
since its being used by the 'biditext' shel script. the newly resulting
biditext still caused netscape to crash with bus error during startup.

i also noticed that you're not using the latest version of r2lgnomepapplet
- which is more visually appealing then the current one, and also
suppports the '--minimal' flag shlomi has requested. i'll send you its
sources in the next email.


"For world domination - press 1,
 or dial 0, and please hold, for the creator." -- nob o. dy

Haifa Linux Club Projects Mailing List (http://linuxclub.il.eu.org)
To unsub send an empty message to [EMAIL PROTECTED]

Reply via email to