Hi Tzafrir,

It seems that things got messed up somehow with the tarball. I downloaded
r2l-0.9.4.tar.gz from


and there are problems compiling it under Solaris.

It seems that there is a problem with the following line in the configure

      fribidi_config_version=`$FRIBIDI_CONFIG $fribidi_config_args \
         --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)\..*/\1.\2.\3/'`

For some reason the fribidi_config_version variable gets messed up (it's
something like 0..)
 After I remove the sed stuff, the configuration script proceeds normally.
However when trying to compile the package

gmake PREFIX=/tmp/emild/r2l-install

the compilation aborts because r2l-config does not exist. I think that the
problem is caused by the fact that install-sh does not allow multiple
files to be copied such as:

install-sh -c file1 file2 dir

Each file must be installed separately. Therefore you should probably
replace the line in r2llib's Makefile with a for loop that installs each
file separately, i.e. replace



        for file in $(PROGS) $(CONFIG_BIN); \
          do $(LIBTOOL) $(INSTALL) -c $$file $(BINDIR) ; \

The compilation proceeds after this but aborts further with
../.././install-sh command not found.

I think that this error is due to some messed up TOPDIR, but I think that
the main reason is that the tarball is somehow not up-to-date.

Also looking at the biditext.in file it seems to be the same as the old
one (i.e. no support for --auto-refresh). This ensures me more that the
problem is with the tarball version.

BTW, the version of biditext I provided will not work on Solaris because
Solaris's sh does not support the syntax

export variable=value

This means that you will have to change such lines to:

export variable



On Wed, 2 Jan 2002, Tzafrir Cohen wrote:

> r2l 0.9.4 is available. Main changes from 0.9.2:
> * the binary r2l is now installed (unless using a system r2llib, because
> it may have a different r2l binary)
> * refreshd_hook.so is optionally loaded when running biditext (using
> --auto-refresh)
> * Everything compiles, also on solaris.
> Things to verify:
> * refreshd on solaris: does it run?
> * Any problems left with tha system version of r2llib ?
> On Fri, 28 Dec 2001, guy keren wrote:
> >
> > On Fri, 28 Dec 2001, Tzafrir Cohen wrote:
> >
> > > I'm generally quite satisfied with this one (even though I have some
> > > problems when trying to build it on other platforms, mainly with
> > > refreshd, I can live with that)
> > >
> > > So I'd like to hear some success stories, and then get 1.0 out.
> >
> > i am trying it out here now (redhat 6.2 with various manual changes).
> >
> > first, some output i see in the configure script's output on the screen:
> >
> > checking for gnome - version >= 1.0... ./configure: test: integer
> > expression expected after-lt
> > yes
> >
> > there's some problem with the test there. i see this again later when
> > checking for another component. running with '-x' reveals the problem is
> > with 'gnome_wanted_micro_version' being set to an empty string, rather
> > then a number,at line 835, and thus the 'test' on line 2581 yields a
> > syntactic error.
> >
> This should be fixed. I modified aclocal/ac_check_generic . I'm not sure
> my solution is optimal, but it seems to work. (I ignore everything after
> the third number)
> > the other component with a problem is 'r2llib'. on line 1014. what happend
> > is that 'r2llib-config --version' here returns '0.32', while the script
> > seems to expect '0.3.2', and this the script sets
> > r2llib_config_micro_version to an empty string. please note that i have a
> > copy of r2llib installed in the system, and i also get a warning about it:
> >
> > configure: warning: Using system version of r2llib from
> > /usr/local/bin/r2llib-config
> >
> This may not be solved.
> > another thing - when i ran 'make install', then after the installation, an
> > 'install' script is being built - either it should be built _before_
> > installing the files, or it shouldn't be built at all - but certainly not
> > be built as the last operation of 'make install'.
> Solved. I needed to use install-sh instead of install.sh . This is a weird
> interaction between autoconf and make.
> >
> > now, running biditext causes applications to crash during startup (tried
> > with 'netscape' [which crashed] and with'gnome-terminal'. gnome-terminal
> > itself didn't crash, but a lynx ran under it crashed with a bus error).
> >
> > i decided perhaps my local copy of r2llib is at fault, so i manually
> > removed it (removing all files from /usr/local/lib/libr2l* and
> > /usr/loacl/bin/r2l*, including the insalled r2l applets). when i did that,
> > the configure script barfed that i don't have a version of 'r2llib', and
> > then barfed that i don't have the right version - it shouldn't go checking
> > the version if it doesn't find the library. nontheless, it ran to the end.
> >
> This warning is very frightening. Maybe make the check for a system r2llib
> optional?
> > the 'r2l' program was not installed in the system - which is not good,
> > since its being used by the 'biditext' shel script.the newly resulting
> > biditext still caused netscape to crash with bus error during startup.
> >
> Done.
> >
> > i also noticed that you're not using the latest version of r2lgnomepapplet
> > - which is more visually appealing then the current one, and also
> > suppports the '--minimal' flag shlomi has requested. i'll send you its
> > sources in the next email.
> >
> What you sent me was an exact copy of what I already have. The gnome
> applet indeed does not support "--minimal".
> --
> Tzafrir Cohen                    /"\
> mailto:[EMAIL PROTECTED]      \ /  ASCII Ribbon Campaign
> Taub 229, 972-4-829-3942,           X   Against  HTML  Mail
> http://www.technion.ac.il/~tzafrir / \
> -------------------------------------------------------------------------
> Haifa Linux Club Projects Mailing List (http://linuxclub.il.eu.org)
> To unsub send an empty message to [EMAIL PROTECTED]

Haifa Linux Club Projects Mailing List (http://linuxclub.il.eu.org)
To unsub send an empty message to [EMAIL PROTECTED]

Reply via email to