We just upgraded our phone servers to the new Incredible PBX (Asterisk
Version: 18.2.1). I couldn't find any other form online that has offered a
suggestion for a fix to a hold issue we had.

When a call came in, audio on both ends worked until that call is placed on
hold from our end for about 15+ minutes. When the call is retrieved from
hold, there is no audio on our end, but sometimes the other end can still
hear us. I could pretty reliably reproduce the issue by calling from my
cell phone into our phone server, placing myself on hold, and then waiting
to retrieve that call for about 15-20+ minutes (anytime the call is
retrieved before that time, audio resumes okay on both ends). Our phone
server at that time then continuously produced the following logs until the
call is terminated by either side:

19243 [2022-10-04 16:44:21] VERBOSE[21514][C-0000001c] res_srtp.c: SRTCP
unprotect failed on SSRC 1667512219 because of replay check failed (index
too old)
19244 [2022-10-04 16:44:21] VERBOSE[21514][C-0000001c] res_srtp.c: SRTP
unprotect failed on SSRC 1667512219 because of authentication failure 160

This message sometimes also appeared:

5904 [2022-10-04 11:21:18] WARNING[27806]
res_pjsip_outbound_registration.c: No response received from
<http://our-telephony-provider.com>***:5060' on registration attempt to
<http://our-telephony-provider.com>***:5060', retrying in '60'

After troubleshooting with several people from our phone providers, PBX,
and Asterisk, we resolved that the cause of this issue was something to do
with "srtpreplayprotection". When we disabled that, everything worked fine.
Asterisk people pointed out that sometimes the user agents (in this case
Linphone) could be buggy. We fixed it with this soulution:

I just wanted to report that here so someone is aware that this issue
exists. here are the link to the forms I posted on:

*IT Systems Administrator*
Linphone-users mailing list

Reply via email to