Hello, All,

This is somewhat off topic, but not really as I am trying to make an external program to control my SM5BSZ WSE boxes in windows XP64. They are nicely controlled via Linrad running under Windows XP64, but I am having trouble compiling and linking the windows version of QT3 to get my separate controller running.

QT3-designer compiles and runs, and my wsecontrol application compiles fine until I try to add the inpout32.dll to it. When I add the lines:

HINSTANCE h_inpout;
h_inpout =    LoadLibrary("C:\inpout32\Win32\npout32.dll");

to my progam without adding an #include <windows.h> I of course get an error message on 'make' that LoadLibrary is undeclared.

When I added an #include <windows.h> I got for several hours today when running 'make' or 'mingw32-make' an error that char* could not be converted to WCHAR* in HINSTANCE. I am not able to take care of this by using an intermediate variable, nor by attempting a static_cast or dynamic_cast.

I played with the code by temporarily adding #install "windef.h" from linrad-02.37, and then began getting on 'make' and 'mingw32-make' reams of errors of the type:

C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:64: error: `WCHAR' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:65: error: `CHAR' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:67: error: `WORD' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:70: error: `SHORT' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:71: error: `SHORT' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:72: error: `SHORT' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:73: error: `SHORT' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:76: error: `DWORD' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:77: error: `BOOL' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:80: error: `SHORT' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:81: error: `SHORT' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:84: error: `DWORD' does not name a type C:/MinGW/bin/../lib/gcc/mingw32/3.4.2/../../../../include/wincon.h:90: error: `WORD' does not name a type

to the tune of 700K errors on a typical compile.

I modifed and then removed the reference to "windef.h" and set my code and #installs in my qt3 program back to what they were originally, and yet I still get the reams of errors as noted above, with both 'make' and 'mingw32-make'. I can't get back to the original single error regarding char* vs WCHAR* types. [And even if I could, I would still have the original problem].

I have tried both the 'stable' 3.3 version of qt3 and the current svn version 3.3.8 [svn 2145]. I am using mingw "current" version 5.1.3 from sourceforge. An earlier version of mingw won't compile qt3.

I previously had printer control working with my XP [32 bit] 'visual basic' widget, but that widget doesn't allow me to set the printer address to 33792, which is what is needed with XP64. I know that inpout32 will allow me to set it, as that is how linrad is controlling the printer. But for some reason my combination of qt3 and mingw32 is not compiling the code necessary to run the dll. I DO have all of this working under Linux, so comments to the effect that I should use Linux are not helpful. I want to understand what is going on and to get this working with Windows XP64.

I put my code at http://www.nitehawk.com/w3sz/form1.ui.h and

, but what I think are the only 2 relevant lines of code are above near the top of this email.

The LARGE error file I generate when I run make [actually, make-mingw32] [810 KB] is at http://nitehawk.com/w3sz/err.log

My Environment settings are at:

Does anyone have any suggestions as to what might be going on here?

A trial of compiling with Microsoft Visual C++ 2005 Express is on hold due to multiple 'path' errors when that route is tried.

I apologize for the bandwidth but I have come to a dead end here. I would have thought that a bit of Googling would give me the answer, but I've been at it all day with no solution yet.

Thanks in advance, and


Roger Rehr

Roger Rehr

This message is sent to you because you are subscribed to
 the mailing list <linrad@antennspecialisten.se>.
To unsubscribe, E-mail to: <[EMAIL PROTECTED]>
To switch to the DIGEST mode, E-mail to <[EMAIL PROTECTED]>
To switch to the INDEX mode, E-mail to <[EMAIL PROTECTED]>
Send administrative queries to  <[EMAIL PROTECTED]>

Reply via email to