On Fri, Jul 12, 2019 at 08:57:45PM +1000, Aleksa Sarai wrote:

> > > @@ -2350,9 +2400,11 @@ static const char *path_init(struct nameidata *nd, 
> > > unsigned flags)
> > >                   s = ERR_PTR(error);
> > >           return s;
> > >   }
> > > - error = dirfd_path_init(nd);
> > > - if (unlikely(error))
> > > -         return ERR_PTR(error);
> > > + if (likely(!nd->path.mnt)) {
> > 
> > Is that a weird way of saying "if we hadn't already called 
> > dirfd_path_init()"?
> 
> Yes. I did it to be more consistent with the other "have we got the
> root" checks elsewhere. Is there another way you'd prefer I do it?

"Have we got the root" checks are inevitable evil; here you are making the
control flow in a single function hard to follow.

I *think* what you are doing is
        absolute pathname, no LOOKUP_BENEATH:
                set_root
                error = nd_jump_root(nd)
        else
                error = dirfd_path_init(nd)
        return unlikely(error) ? ERR_PTR(error) : s;
which should be a lot easier to follow (not to mention shorter), but I might
be missing something in all of that.

Reply via email to