linux-bcachefs
Thread
Date
Earlier messages
Later messages
Messages by Thread
[syzbot] [bcachefs?] kernel BUG in bch2_bucket_alloc_trans (2)
syzbot
Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Christopher Snowhill
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Malte Schröder
Re: Another bcachefs version downgrade bug
Martin Steigerwald
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Jani Partanen
Re: Another bcachefs version downgrade bug
Malte Schröder
Re: Another bcachefs version downgrade bug
Jani Partanen
Re: Another bcachefs version downgrade bug
Kent Overstreet
Re: Another bcachefs version downgrade bug
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Kent Overstreet
Mounting multiple versions/snapshots/images at the same time (was: Re: Another bcachefs version downgrade bug)
Martin Steigerwald
Re: Mounting multiple versions/snapshots/images at the same time (was: Re: Another bcachefs version downgrade bug)
Carl E. Thompson
Re: Another bcachefs version downgrade bug
Martin Steigerwald
[PATCH] bcachefs: Correct the description of the '--bucket=size' options
Youling Tang
Re: [PATCH] bcachefs: Correct the description of the '--bucket=size' options
Youling Tang
Re: [PATCH] bcachefs: Correct the description of the '--bucket=size' options
Kent Overstreet
[PATCH v2] bcachefs: Simplify code in bch2_dev_alloc()
Youling Tang
[GIT PULL] bcachefs fixes for 6.12-rc4
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc4
pr-tracker-bot
Re: [GIT PULL] bcachefs fixes for 6.12-rc4
pr-tracker-bot
[syzbot] Monthly bcachefs report (Oct 2024)
syzbot
[PATCH 1/2] bcachefs: Fix kasan splat in new_stripe_alloc_buckets()
Kent Overstreet
[PATCH 2/2] bcachefs: Handle race between stripe reuse, invalidate_stripe_to_dev
Kent Overstreet
Re: btree_path_up_until_good_node
Kent Overstreet
[syzbot] [bcachefs?] kernel panic: bcachefs (loop3): panic after error
syzbot
Re: [syzbot] [bcachefs?] kernel panic: bcachefs (loop3): panic after error
Kent Overstreet
Re: [syzbot] [bcachefs?] kernel panic: bcachefs (loop3): panic after error
syzbot
Re: [syzbot] [bcachefs?] kernel panic: bcachefs (loop3): panic after error
Alan Huang
[PATCH] bcachefs: Fix incorrect a year to seconds calculation
Naoki MATSUMOTO
Re: [PATCH] bcachefs: Fix incorrect a year to seconds calculation
Kent Overstreet
[PATCH] bcachefs: Add missing validation for bch_stripe.csum_granularity_bits
Kent Overstreet
[PATCH] bcachefs: Fix missing bounds checks in bch2_alloc_read()
Kent Overstreet
[PATCH] bcachefs: fix uaf in bch2_dio_write_done()
Kent Overstreet
[PATCH] bcachefs: Fix sysfs warning in fstests generic/730,731
Kent Overstreet
Re: [PATCH] bcachefs: Fix sysfs warning in fstests generic/730,731
Christoph Hellwig
Re: [PATCH] bcachefs: Fix sysfs warning in fstests generic/730,731
Greg Kroah-Hartman
Re: [PATCH] bcachefs: Fix sysfs warning in fstests generic/730,731
Kent Overstreet
Re: [PATCH] bcachefs: Fix sysfs warning in fstests generic/730,731
Greg Kroah-Hartman
Re: [PATCH] bcachefs: Fix sysfs warning in fstests generic/730,731
Kent Overstreet
[PATCH bcachefs-tools] Pass -C default-linker-libraries to rustc
Alyssa Ross
Re: [PATCH bcachefs-tools] Pass -C default-linker-libraries to rustc
Kent Overstreet
[PATCH bcachefs-tools] Avoid static linking conflicts with libblkid
Alyssa Ross
Re: [PATCH bcachefs-tools] Avoid static linking conflicts with libblkid
Kent Overstreet
Libmount bug ?
Alan Huang
Re: Libmount bug ?
Karel Zak
Re: Libmount bug ?
Alan Huang
[PATCH] bcachefs: Simplify code in bch2_dev_alloc()
Youling Tang
Re: [PATCH] bcachefs: Simplify code in bch2_dev_alloc()
Kent Overstreet
Re: [PATCH] bcachefs: Simplify code in bch2_dev_alloc()
Youling Tang
[PATCH] bcachefs: Fix accounting replay flags
Kent Overstreet
[PATCH] bcachefs: Fix bch2_have_enough_devs() for BCH_SB_MEMBER_INVALID
Kent Overstreet
[PATCH] bcachefs: Fix invalid shift in member_to_text()
Kent Overstreet
Re: [PATCH] bcachefs: Fix invalid shift in member_to_text()
Hongbo Li
Re: [PATCH] bcachefs: Fix invalid shift in member_to_text()
Kent Overstreet
Re: [PATCH resend v2] bcachefs: reject unknown mount options
Janpieter Sollie
[PATCH next] bcachefs: Fix bitwise math on 32 bit systems
Dan Carpenter
Re: [PATCH next] bcachefs: Fix bitwise math on 32 bit systems
Kent Overstreet
[syzbot] [block?] [bcachefs?] KASAN: slab-use-after-free Read in percpu_ref_put (2)
syzbot
[PATCH] bcachefs: Do not allow no fail lock request to fail
Alan Huang
Re: [PATCH] bcachefs: Do not allow no fail lock request to fail
Kent Overstreet
Re: [PATCH] bcachefs: Do not allow no fail lock request to fail
Alan Huang
[PATCH] cmd_device_add: Allow setting durability when adding a device
Kazunari Sasa
[PATCH] bcachefs: skip mount option handle for empty string.
Hongbo Li
[PATCH] bcachefs: Disk accounting device validation fixes
Kent Overstreet
[PATCH] bcachefs: bch2_inode_or_descendents_is_open()
Kent Overstreet
[PATCH 1/2] closures: Add closure_wait_event_timeout()
Kent Overstreet
[PATCH 2/2] bcachefs: Check if stuck in journal_res_get()
Kent Overstreet
Re: [PATCH 1/2] closures: Add closure_wait_event_timeout()
Coly Li
[PATCH v3] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Zhao Mengmeng
Re: [PATCH v3] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Hongbo Li
Re: [PATCH v3] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Kent Overstreet
Re: [PATCH v3] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Zhao Mengmeng
[bug report] bcachefs: bcachefs_metadata_version_inode_has_child_snapshots
Dan Carpenter
Re: [bug report] bcachefs: bcachefs_metadata_version_inode_has_child_snapshots
Kent Overstreet
[PATCH v2] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Zhao Mengmeng
Re: [PATCH v2] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Hongbo Li
Re: [PATCH v2] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Hongbo Li
Re: [PATCH v2] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Zhao Mengmeng
Re: [PATCH v2] bcachefs: Fix shift-out-of-bounds in bch2_stripe_to_text
Hongbo Li
[PATCH] jfs: add a check to prevent array-index-out-of-bounds
Nihar Chaithanya
Re: [PATCH] jfs: add a check to prevent array-index-out-of-bounds
Dave Kleikamp
[PATCH] bcachefs: Fix state lock involved deadlock
Alan Huang
Re: [PATCH] bcachefs: Fix state lock involved deadlock
Kent Overstreet
[PATCH] bcachefs: Release transaction before wake up
Alan Huang
Re: [PATCH] bcachefs: Release transaction before wake up
Kent Overstreet
[syzbot] [bcachefs?] WARNING in __bch2_fsck_err (2)
syzbot
Re: [syzbot] [bcachefs?] WARNING in __bch2_fsck_err (2)
Kent Overstreet
[PATCH v1] bcachefs: use mutex_trylock in bch2_replicas_entry_validate
Piotr Zalewski
Re: [PATCH v1] bcachefs: use mutex_trylock in bch2_replicas_entry_validate
Kent Overstreet
[PATCH][next] bcachefs: remove superfluous ; after statements
Colin Ian King
[GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Linus Torvalds
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Linus Torvalds
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Linus Torvalds
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Theodore Ts'o
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Linus Torvalds
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Alan Huang
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Jason A. Donenfeld
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Jason A. Donenfeld
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Jann Horn
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Theodore Ts'o
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Theodore Ts'o
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Daniel Gomez
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Martin Steigerwald
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Martin Steigerwald
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Carl E. Thompson
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Carl E. Thompson
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Josef Bacik
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
Kent Overstreet
Re: [GIT PULL] bcachefs fixes for 6.12-rc2
pr-tracker-bot
[PATCH 0/5] Fixes for snapshots + unlink
Kent Overstreet
[PATCH 3/5] bcachefs: btree_iter_peek_upto() now handles BTREE_ITER_all_snapshots
Kent Overstreet
[PATCH 4/5] bcachefs: Delete vestigal check_inode() checks
Kent Overstreet
[PATCH 2/5] bcachefs: reattach_inode() now correctly handles interior snapshot nodes
Kent Overstreet
[PATCH 5/5] bcachefs: bcachefs_metadata_version_inode_has_child_snapshots
Kent Overstreet
[PATCH 1/5] bcachefs: Split out check_unreachable_inodes() pass
Kent Overstreet
[PATCH resend v3] bcachefs: Fix NULL pointer dereference in bch2_opt_to_text
Mohammed Anees
Re: [PATCH resend v3] bcachefs: Fix NULL pointer dereference in bch2_opt_to_text
Hongbo Li
Re: [PATCH resend v3] bcachefs: Fix NULL pointer dereference in bch2_opt_to_text
Mohammed Anees
Re: [PATCH resend v3] bcachefs: Fix NULL pointer dereference in bch2_opt_to_text
Hongbo Li
Re: [PATCH resend v3] bcachefs: Fix NULL pointer dereference in bch2_opt_to_text
Kent Overstreet
[PATCH TOOLS] fuse: graceful shutdown when startup fails
Thomas Bertschinger
Re: [PATCH TOOLS] fuse: graceful shutdown when startup fails
Kent Overstreet
Re: [PATCH v3] bcachefs: Fix NULL pointer dereference in bch2_opt_to_text
Mohammed Anees
[syzbot] [bcachefs?] possible deadlock in bch2_replicas_entry_validate
syzbot
Re: [PATCH] Add support for true/false, yes/no & on/off in bool-type options
Integral
Re: [PATCH] Add support for true/false, yes/no & on/off in bool-type options
Integral
Re: [PATCH] Add support for true/false, yes/no & on/off in bool-type options
Alan Huang
[PATCH v2] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v2] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v2] bcachefs: add support for true/false & yes/no in bool-type options
Hongbo Li
[PATCH v3] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v3] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v3] bcachefs: add support for true/false & yes/no in bool-type options
Hongbo Li
[PATCH v4] libbcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v4] libbcachefs: add support for true/false & yes/no in bool-type options
Hongbo Li
Re: [PATCH v4] libbcachefs: add support for true/false & yes/no in bool-type options
Alan Huang
[PATCH v5] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v5] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v5] bcachefs: add support for true/false & yes/no in bool-type options
Alan Huang
Re: [PATCH v5] bcachefs: add support for true/false & yes/no in bool-type options
Integral
Re: [PATCH v5] bcachefs: add support for true/false & yes/no in bool-type options
Integral
[syzbot] [bcachefs?] kernel BUG in __bch2_btree_node_write
syzbot
Re: [syzbot] [bcachefs?] kernel BUG in __bch2_btree_node_write
syzbot
[PATCH 1/4] bcachefs: Convert open-coded lock_graph_pop_all to helper
Alan Huang
[PATCH 2/4] bcachefs: Introduce lock_graph_pop_from
Alan Huang
[PATCH 3/4] bcachefs: Only abort the transactions in the cycle
Alan Huang
[PATCH 4/4] bcachefs: Pop all the transactions from the abort one
Alan Huang
[syzbot] [bcachefs?] UBSAN: shift-out-of-bounds in __btree_node_pinned
syzbot
Re: [syzbot] [bcachefs?] UBSAN: shift-out-of-bounds in __btree_node_pinned
syzbot
[RFC PATCH 0/7] vfs: improving inode cache iteration scalability
Dave Chinner
[PATCH 7/7] bcachefs: implement sb->iter_vfs_inodes
Dave Chinner
[PATCH 2/7] vfs: add inode iteration superblock method
Dave Chinner
Re: [PATCH 2/7] vfs: add inode iteration superblock method
Christoph Hellwig
Re: [PATCH 2/7] vfs: add inode iteration superblock method
Dave Chinner
Re: [PATCH 2/7] vfs: add inode iteration superblock method
kernel test robot
[PATCH 1/7] vfs: replace invalidate_inodes() with evict_inodes()
Dave Chinner
Re: [PATCH 1/7] vfs: replace invalidate_inodes() with evict_inodes()
Christoph Hellwig
Re: [PATCH 1/7] vfs: replace invalidate_inodes() with evict_inodes()
Jan Kara
[PATCH 5/7] vfs: add inode iteration superblock method
Dave Chinner
Re: [PATCH 5/7] vfs: add inode iteration superblock method
Christoph Hellwig
[PATCH 3/7] vfs: convert vfs inode iterators to super_iter_inodes_unsafe()
Dave Chinner
Re: [PATCH 3/7] vfs: convert vfs inode iterators to super_iter_inodes_unsafe()
Christoph Hellwig
Re: [PATCH 3/7] vfs: convert vfs inode iterators to super_iter_inodes_unsafe()
Dave Chinner
Re: [PATCH 3/7] vfs: convert vfs inode iterators to super_iter_inodes_unsafe()
kernel test robot
[PATCH 6/7] xfs: implement sb->iter_vfs_inodes
Dave Chinner
Re: [PATCH 6/7] xfs: implement sb->iter_vfs_inodes
Christoph Hellwig
[PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Dave Chinner
lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Christoph Hellwig
Re: lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Christoph Hellwig
Re: lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Jan Kara
Re: lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Christoph Hellwig
Re: lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Jan Kara
Re: lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Christoph Hellwig
Re: lsm sb_delete hook, was Re: [PATCH 4/7] vfs: Convert sb->s_inodes iteration to super_iter_inodes()
Jan Kara
Earlier messages
Later messages