On Sat, 2017-09-16 at 19:37 -0700, Waiman Long wrote:
> diff --git a/include/linux/fs.h b/include/linux/fs.h
> index 339e737..330b572 100644
> --- a/include/linux/fs.h
> +++ b/include/linux/fs.h
> @@ -448,7 +448,7 @@ struct block_device {
>  
>       /* The counter of freeze processes */
>       int                     bd_fsfreeze_count;
> -     /* Mutex for freeze */
> +     /* Mutex for freeze and blktrace */
>       struct mutex            bd_fsfreeze_mutex;
>  } __randomize_layout;

This patch changes the meaning of bd_fsfreeze_mutex significantly. Please rename
that mutex such that its name matches its new role.

Thanks,

Bart.

Reply via email to