On Tue, Aug 27, 2019 at 02:46:27PM +0300, Nikolay Borisov wrote:
> This series cleans up the calling convention of the 2 function used to search 
> the INODE_REF items for the presence of particular name. Namely, I switch the 
> 2
> functions to directly return a struct btrfs_inode_(ext)?ref. This reduces the 
> number of parameters when calling the functions. 
> 
> While doing the aforementioned cleanup I stumbled upon backref_in_log which 
> was 
> opencoding btrfs_find_name_in_backref hence I just refactored the function. 
> 
> This series survived xfstest. 
> 
> Nikolay Borisov (3):
>   btrfs: Make btrfs_find_name_in_backref return btrfs_inode_ref struct
>   btrfs: Make btrfs_find_name_in_ext_backref return struct
>     btrfs_inode_extref
>   btrfs: Use btrfs_find_name_in_backref in backref_in_log

1 and 2 merged to misc-next, thanks.

Reply via email to