On Sat, Jan 23, 2021 at 05:50:52PM +0000, Nick Terrell wrote:
> 
> 
> > On Jan 22, 2021, at 1:58 AM, Nikolay Borisov <nbori...@suse.com> wrote:
> > 
> > Those constants are really used internally by zstd and including
> > linux/zstd.h into users results in the following warnings:
> > 
> > In file included from fs/btrfs/zstd.c:19:
> > ./include/linux/zstd.h:798:21: warning: ‘ZSTD_skippableHeaderSize’ defined 
> > but not used [-Wunused-const-variable=]
> >  798 | static const size_t ZSTD_skippableHeaderSize = 8;
> >      |                     ^~~~~~~~~~~~~~~~~~~~~~~~
> > ./include/linux/zstd.h:796:21: warning: ‘ZSTD_frameHeaderSize_max’ defined 
> > but not used [-Wunused-const-variable=]
> >  796 | static const size_t ZSTD_frameHeaderSize_max = 
> > ZSTD_FRAMEHEADERSIZE_MAX;
> >      |                     ^~~~~~~~~~~~~~~~~~~~~~~~
> > ./include/linux/zstd.h:795:21: warning: ‘ZSTD_frameHeaderSize_min’ defined 
> > but not used [-Wunused-const-variable=]
> >  795 | static const size_t ZSTD_frameHeaderSize_min = 
> > ZSTD_FRAMEHEADERSIZE_MIN;
> >      |                     ^~~~~~~~~~~~~~~~~~~~~~~~
> > ./include/linux/zstd.h:794:21: warning: ‘ZSTD_frameHeaderSize_prefix’ 
> > defined but not used [-Wunused-const-variable=]
> >  794 | static const size_t ZSTD_frameHeaderSize_prefix = 5;
> > 
> > So fix those warnings by turning the constants into defines.
> > 
> > Signed-off-by: Nikolay Borisov <nbori...@suse.com>
> > ---
> > include/linux/zstd.h | 8 ++++----
> > 1 file changed, 4 insertions(+), 4 deletions(-)
> > 
> > diff --git a/include/linux/zstd.h b/include/linux/zstd.h
> > index 249575e2485f..e87f78c9b19c 100644
> > --- a/include/linux/zstd.h
> > +++ b/include/linux/zstd.h
> > @@ -791,11 +791,11 @@ size_t ZSTD_DStreamOutSize(void);
> > /* for static allocation */
> > #define ZSTD_FRAMEHEADERSIZE_MAX 18
> > #define ZSTD_FRAMEHEADERSIZE_MIN  6
> > -static const size_t ZSTD_frameHeaderSize_prefix = 5;
> > -static const size_t ZSTD_frameHeaderSize_min = ZSTD_FRAMEHEADERSIZE_MIN;
> > -static const size_t ZSTD_frameHeaderSize_max = ZSTD_FRAMEHEADERSIZE_MAX;
> > +#define ZSTD_frameHeaderSize_prefix 5
> > +#define ZSTD_frameHeaderSize_min ZSTD_FRAMEHEADERSIZE_MIN
> > +#define ZSTD_frameHeaderSize_max ZSTD_FRAMEHEADERSIZE_MAX
> > /* magic number + skippable frame length */
> > -static const size_t ZSTD_skippableHeaderSize = 8;
> > +#define ZSTD_skippableHeaderSize 8
> > 
> > 
> > /*-*************************************
> This looks good to me! We removed these constants from the upstream header a
> while ago, for similar reasons.
> 
> You can add:
> 
> Reviewed-by: Nick Terrell <terre...@fb.com>

Thank you, patch added to misc-next, the warning -Wunused-const-variable
added back to Makefile.

Reply via email to