On Fri, 2 Mar 2018 15:10:14 +0100
Jiri Slaby <jsl...@suse.cz> wrote:

> in openSUSE, sphinx was updated to 1.7.1 and kernel-doc cannot be built
> since that time:
> Running Sphinx v1.7.1
> Extension error:
> Could not import extension kerneldoc (exception: cannot import name
> 'Directive')
> It is because sphinx.util.compat.* was removed from sphinx in 1.7 since
> it was deprecated for a long time:
> "sphinx.util.compat.%s is deprecated and will be removed "
>                "in Sphinx 1.7, please use docutils' instead."
> Could you fix that up? python is not my favourite interpreter so fixing
> it myself is not feasible on my side.

I got a patch from Takashi this very morning for that problem; I guess
I'll have to fast-track it Linusward.


To unsubscribe from this list: send the line "unsubscribe linux-doc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to