linux-doc
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH v23 10/28] riscv/mm: Implement map_shadow_stack() syscall
Deepak Gupta via B4 Relay
Re: [PATCH v23 10/28] riscv/mm: Implement map_shadow_stack() syscall
Andreas Korb
[PATCH v23 11/28] riscv/shstk: If needed allocate a new shadow stack on clone
Deepak Gupta via B4 Relay
[PATCH v23 12/28] riscv: Implements arch agnostic shadow stack prctls
Deepak Gupta via B4 Relay
Re: [PATCH v23 12/28] riscv: Implements arch agnostic shadow stack prctls
Andreas Korb
[PATCH v23 16/28] riscv: signal: abstract header saving for setup_sigcontext
Deepak Gupta via B4 Relay
Re: [PATCH v23 16/28] riscv: signal: abstract header saving for setup_sigcontext
Andreas Korb
[PATCH v23 17/28] riscv/signal: save and restore of shadow stack for signal
Deepak Gupta via B4 Relay
[PATCH v23 18/28] riscv/kernel: update __show_regs to print shadow stack register
Deepak Gupta via B4 Relay
Re: [PATCH v23 16/28] riscv: signal: abstract header saving for setup_sigcontext[PATCH v23 18/28] riscv/kernel: update __show_regs to print shadow stack register
Andreas Korb
[PATCH v23 19/28] riscv/ptrace: riscv cfi status and state via ptrace and in core files
Deepak Gupta via B4 Relay
[PATCH v23 21/28] riscv: kernel command line option to opt out of user cfi
Deepak Gupta via B4 Relay
Re: [PATCH v23 21/28] riscv: kernel command line option to opt out of user cfi
Paul Walmsley
[PATCH v23 25/28] riscv: create a config for shadow stack and landing pad instr support
Deepak Gupta via B4 Relay
Re: [PATCH v23 25/28] riscv: create a config for shadow stack and landing pad instr support
Andreas Korb
[PATCH v23 26/28] riscv: Documentation for landing pad / indirect branch tracking
Deepak Gupta via B4 Relay
[PATCH v23 20/28] riscv/hwprobe: zicfilp / zicfiss enumeration in hwprobe
Deepak Gupta via B4 Relay
[PATCH v23 24/28] arch/riscv: dual vdso creation logic and select vdso based on hw
Deepak Gupta via B4 Relay
Re: [PATCH v23 24/28] arch/riscv: dual vdso creation logic and select vdso based on hw
Andreas Korb
Re: [PATCH v23 24/28] arch/riscv: dual vdso creation logic and select vdso based on hw
Thomas Weißschuh
Re: [PATCH v23 24/28] arch/riscv: dual vdso creation logic and select vdso based on hw
Charles Mirabile
[PATCH v23 23/28] arch/riscv: compile vdso with landing pad and shadow stack note
Deepak Gupta via B4 Relay
Re: [PATCH v23 23/28] arch/riscv: compile vdso with landing pad and shadow stack note
Andreas Korb
[PATCH v23 27/28] riscv: Documentation for shadow stack on riscv
Deepak Gupta via B4 Relay
[PATCH v23 28/28] kselftest/riscv: kselftest for user mode cfi
Deepak Gupta via B4 Relay
Re: [PATCH v23 00/28] riscv control-flow integrity for usermode
patchwork-bot+linux-riscv
Re: [PATCH v23 00/28] riscv control-flow integrity for usermode
patchwork-bot+linux-riscv
Re: [PATCH v23 00/28] riscv control-flow integrity for usermode
Paul Walmsley
Re: [PATCH v23 00/28] riscv control-flow integrity for usermode
Valentin Haudiquet
[PATCH 0/9] mm/damon: misc cleanups
SeongJae Park
Re: [RFC 0/2] Add AI coding assistant configuration to Linux kernel
Jarkko Sakkinen
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Jiaqi Yan
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Mauro Carvalho Chehab
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Oliver Upton
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Oliver Upton
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Jiaqi Yan
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Oliver Upton
Re: [PATCH v4 0/3] VMM can handle guest SEA via KVM_EXIT_ARM_SEA
Jiaqi Yan
Re: [PATCH v7 00/12] Direct Map Removal Support for guest_memfd
Brendan Jackman
Re: [PATCH v7 00/12] Direct Map Removal Support for guest_memfd
Nikita Kalyazin
Re: [PATCH v7 00/12] Direct Map Removal Support for guest_memfd
Brendan Jackman
Re: [PATCH v7 00/12] Direct Map Removal Support for guest_memfd
Nikita Kalyazin
Re: [PATCH v7 00/12] Direct Map Removal Support for guest_memfd
Brendan Jackman
Re: [PATCH v7 00/12] Direct Map Removal Support for guest_memfd
Brendan Jackman
[PATCH v4] checkpatch: add uninitialized pointer with __free attribute check
Ally Heev
[PATCH RESEND 0/5] release of KTAP version 2
Rae Moar
[PATCH RESEND 1/5] ktap_v2: change version to 2-rc in KTAP specification
Rae Moar
[PATCH RESEND 2/5] ktap_v2: change "version 1" to "version 2" in examples
Rae Moar
[PATCH RESEND 3/5] ktap_v2: add test metadata
Rae Moar
[PATCH RESEND 4/5] ktap_v2: formatting fixes to ktap spec
Rae Moar
[PATCH RESEND 5/5] ktap_v2: change version to 2 in KTAP specification
Rae Moar
[PATCH v6 0/2] platform/chrome: Fix an UAF via revocable primitive APIs
Tzung-Bi Shih
[PATCH v6 1/2] platform/chrome: Protect cros_ec_device lifecycle with revocable
Tzung-Bi Shih
Re: [PATCH v6 1/2] platform/chrome: Protect cros_ec_device lifecycle with revocable
kernel test robot
Re: [PATCH v6 1/2] platform/chrome: Protect cros_ec_device lifecycle with revocable
kernel test robot
[PATCH v6 2/2] platform/chrome: cros_ec_chardev: Consume cros_ec_device via revocable
Tzung-Bi Shih
Re: [PATCH v6 2/2] platform/chrome: cros_ec_chardev: Consume cros_ec_device via revocable
Jason Gunthorpe
Re: [PATCH v6 2/2] platform/chrome: cros_ec_chardev: Consume cros_ec_device via revocable
Tzung-Bi Shih
Re: [PATCH v6 2/2] platform/chrome: cros_ec_chardev: Consume cros_ec_device via revocable
Jason Gunthorpe
[PATCH v6 0/3] drivers/base: Introduce revocable
Tzung-Bi Shih
[PATCH v6 1/3] revocable: Revocable resource management
Tzung-Bi Shih
Re: [PATCH v6 1/3] revocable: Revocable resource management
Danilo Krummrich
[PATCH v6 3/3] selftests: revocable: Add kselftest cases
Tzung-Bi Shih
[PATCH v6 2/3] revocable: Add Kunit test cases
Tzung-Bi Shih
[PATCH v6 0/3] platform/chrome: Fix an UAF via replacing fops
Tzung-Bi Shih
[PATCH v6 3/3] platform/chrome: cros_ec_chardev: Secure cros_ec_device via revocable
Tzung-Bi Shih
[PATCH v6 2/3] char: misc: Leverage revocable fops replacement
Tzung-Bi Shih
[PATCH v6 1/3] revocable: Add fops replacement
Tzung-Bi Shih
Re: [PATCH v6 1/3] revocable: Add fops replacement
Jason Gunthorpe
Re: [PATCH v6 1/3] revocable: Add fops replacement
Tzung-Bi Shih
Re: [PATCH v6 1/3] revocable: Add fops replacement
Jason Gunthorpe
Re: [PATCH v6 1/3] revocable: Add fops replacement
Tzung-Bi Shih
Re: [PATCH v6 1/3] revocable: Add fops replacement
Jason Gunthorpe
Re: [PATCH v6 1/3] revocable: Add fops replacement
kernel test robot
Re: [PATCH v6 1/3] revocable: Add fops replacement
kernel test robot
[PATCH] Documentation: btt: Unwrap bit 31-30 nested table
Bagas Sanjaya
Re: [PATCH] Documentation: btt: Unwrap bit 31-30 nested table
Alison Schofield
Re: [PATCH] Documentation: btt: Unwrap bit 31-30 nested table
Randy Dunlap
[PATCH net-next v6 0/6] net: devmem: improve cpu cost of RX token management
Bobby Eshleman
[PATCH net-next v6 3/6] net: devmem: prepare for autorelease rx token management
Bobby Eshleman
Re: [PATCH net-next v6 3/6] net: devmem: prepare for autorelease rx token management
kernel test robot
Re: [PATCH net-next v6 3/6] net: devmem: prepare for autorelease rx token management
kernel test robot
Re: [PATCH net-next v6 3/6] net: devmem: prepare for autorelease rx token management
Dan Carpenter
Re: [PATCH net-next v6 3/6] net: devmem: prepare for autorelease rx token management
Dan Carpenter
[PATCH net-next v6 1/6] net: devmem: rename tx_vec to vec in dmabuf binding
Bobby Eshleman
[PATCH net-next v6 2/6] net: devmem: refactor sock_devmem_dontneed for autorelease split
Bobby Eshleman
[PATCH net-next v6 4/6] net: devmem: add SO_DEVMEM_AUTORELEASE for autorelease control
Bobby Eshleman
Re: [PATCH net-next v6 4/6] net: devmem: add SO_DEVMEM_AUTORELEASE for autorelease control
kernel test robot
[PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Bobby Eshleman
Re: [PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Stanislav Fomichev
Re: [PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Mina Almasry
Re: [PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Stanislav Fomichev
Re: [PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Stanislav Fomichev
Re: [PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Bobby Eshleman
Re: [PATCH net-next v6 5/6] net: devmem: document SO_DEVMEM_AUTORELEASE socket option
Bobby Eshleman
[PATCH net-next v6 6/6] net: devmem: add tests for SO_DEVMEM_AUTORELEASE socket option
Bobby Eshleman
[PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Shenwei Wang
[PATCH v5 1/5] dt-bindings: remoteproc: imx_rproc: Add "rpmsg" subnode support
Shenwei Wang
Re: [PATCH v5 1/5] dt-bindings: remoteproc: imx_rproc: Add "rpmsg" subnode support
Andrew Lunn
Re: [PATCH v5 1/5] dt-bindings: remoteproc: imx_rproc: Add "rpmsg" subnode support
Rob Herring
Re: [PATCH v5 1/5] dt-bindings: remoteproc: imx_rproc: Add "rpmsg" subnode support
Shenwei Wang
[PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Shenwei Wang
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Peng Fan
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Andrew Lunn
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Mathieu Poirier
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Shenwei Wang
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Mathieu Poirier
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Shenwei Wang
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Mathieu Poirier
Re: [PATCH v5 2/5] remoteproc: imx_rproc: Populate devices under "rpmsg" subnode
Shenwei Wang
[PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Linus Walleij
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Andrew Lunn
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Rob Herring
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Daniel Baluta
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Randy Dunlap
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Shenwei Wang
Re: [PATCH v5 3/5] docs: staging: gpio-rpmsg: gpio over rpmsg bus
Randy Dunlap
[PATCH v5 5/5] arm64: dts: imx8ulp: Add rpmsg node under imx_rproc
Shenwei Wang
[PATCH v5 4/5] gpio: imx-rpmsg: add imx-rpmsg GPIO driver
Shenwei Wang
Re: [PATCH v5 4/5] gpio: imx-rpmsg: add imx-rpmsg GPIO driver
Peng Fan
Re: [PATCH v5 4/5] gpio: imx-rpmsg: add imx-rpmsg GPIO driver
Zhongqiu Han
Re: [PATCH v5 4/5] gpio: imx-rpmsg: add imx-rpmsg GPIO driver
Shenwei Wang
RE: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Peng Fan
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Arnaud POULIQUEN
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Shenwei Wang
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Arnaud POULIQUEN
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Shenwei Wang
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Arnaud POULIQUEN
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Andrew Lunn
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Shenwei Wang
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Mathieu Poirier
Re: [PATCH v5 0/5] Enable Remote GPIO over RPMSG on i.MX Platform
Mathieu Poirier
[PATCH v8 00/15] Consolidate iommu page table implementations (AMD)
Jason Gunthorpe
[PATCH v8 08/15] iommupt: Add read_and_clear_dirty op
Jason Gunthorpe
Re: [PATCH v8 08/15] iommupt: Add read_and_clear_dirty op
Randy Dunlap
Re: [PATCH v8 08/15] iommupt: Add read_and_clear_dirty op
Jason Gunthorpe
Re: [PATCH v8 08/15] iommupt: Add read_and_clear_dirty op
Randy Dunlap
[PATCH v8 02/15] genpt: Add Documentation/ files
Jason Gunthorpe
Re: [PATCH v8 02/15] genpt: Add Documentation/ files
Randy Dunlap
Re: [PATCH v8 02/15] genpt: Add Documentation/ files
Jason Gunthorpe
[PATCH v8 12/15] iommupt: Add the x86 64 bit page table format
Jason Gunthorpe
[PATCH v8 05/15] iommupt: Add iova_to_phys op
Jason Gunthorpe
Re: [PATCH v8 05/15] iommupt: Add iova_to_phys op
Randy Dunlap
Re: [PATCH v8 05/15] iommupt: Add iova_to_phys op
Jason Gunthorpe
[PATCH v8 04/15] iommupt: Add the AMD IOMMU v1 page table format
Jason Gunthorpe
Re: [PATCH v8 04/15] iommupt: Add the AMD IOMMU v1 page table format
Randy Dunlap
[PATCH v8 15/15] iommupt: Add a kunit test for the IOMMU implementation
Jason Gunthorpe
[PATCH v8 10/15] iommupt: Add a mock pagetable format for iommufd selftest to use
Jason Gunthorpe
[PATCH v8 06/15] iommupt: Add unmap_pages op
Jason Gunthorpe
[PATCH v8 03/15] iommupt: Add the basic structure of the iommu implementation
Jason Gunthorpe
[PATCH v8 13/15] iommu/amd: Use the generic iommu page table
Jason Gunthorpe
Re: [PATCH v8 13/15] iommu/amd: Use the generic iommu page table
Ankit Soni
Re: [PATCH v8 13/15] iommu/amd: Use the generic iommu page table
Jason Gunthorpe
Re: [PATCH v8 13/15] iommu/amd: Use the generic iommu page table
Lai, Yi
Re: [PATCH v8 13/15] iommu/amd: Use the generic iommu page table
Jason Gunthorpe
Re: [PATCH v8 13/15] iommu/amd: Use the generic iommu page table
Alejandro Jimenez
[PATCH v8 14/15] iommu/amd: Remove AMD io_pgtable support
Jason Gunthorpe
[PATCH v8 01/15] genpt: Generic Page Table base API
Jason Gunthorpe
[PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Alexey Kardashevskiy
Re: [PATCH v8 07/15] iommupt: Add map_pages op
Jason Gunthorpe
[PATCH v8 09/15] iommupt: Add a kunit test for Generic Page Table
Jason Gunthorpe
[PATCH v8 11/15] iommufd: Change the selftest to use iommupt instead of xarray
Jason Gunthorpe
Re: [PATCH v8 00/15] Consolidate iommu page table implementations (AMD)
Joerg Roedel
Re: [PATCH v8 00/15] Consolidate iommu page table implementations (AMD)
Jason Gunthorpe
Earlier messages
Later messages