On Wed, 4 Jan 2023 15:28:42 +0800 Xiang Gao <[email protected]> wrote:
> On 2023/1/4 15:26, Yue Hu wrote: > > ... > > >> > >> I think we could just export parts of erofs_pread() to clean up the > >> whole erofs_verify_inode_data()... > > > > What's the clean up referring to? > > > > However, i think erofs_verify_inode_data() looks a little duplicate > > compared to erofs_read_raw_data/z_erofs_read_data(). > > We should reuse the main part (for example, by introducing an interface > to accept mapping) of > erofs_read_raw_data() and z_erofs_read_data() to avoid duplicated code > in erofs_verify_inode_data(). Yes, it's. Let's do it. > > Thanks, > Gao Xiang > > > > >> > >> Thanks, > >> Gao Xiang > >> > >>
