On Sun, Apr 03, 2016 at 12:21:53AM -0500, Eric Biggers wrote:
> Rename fscrypt_complete() to page_crypt_complete(). This callback is
> specifically for data pages; fscrypto also performs filename encryption.
>
> Rename dir_crypt_complete() to fname_crypt_complete(). This callback is
> also used for symlink targets, not just directory entries.
>
> Rename fscrypt_process_policy() to fscrypt_set_policy(). The new name
> better matches the ioctl, and it goes along with fscrypt_get_policy().
>
> Signed-off-by: Eric Biggers <[email protected]>
I'd really rather not renaming any globally visible functions until
after ext4 is converted over to use fs/crypto, just to avoid confusion.
Cheers,
- Ted
------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://pubads.g.doubleclick.net/gampad/clk?id=278785471&iu=/4140
_______________________________________________
Linux-f2fs-devel mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/linux-f2fs-devel